Node attribute shortcuts in node editor not working in 2014?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  06 June 2013
Node attribute shortcuts in node editor not working in 2014?

Heya,

Is it just me, or the shortcuts in the node editor for attributes (Alt + S/C/F) appear and all, but don't quite work?
In my case they are overtaken by the viewport's, and fail to affect the nodes in the node editor.

Were working fine in 2013 all along (upped to 2014 only this week).

Just looking for confirmation or not before I waste my time digging, or AD's by submitting a non-bug.

Cheers
__________________
Come, Join the Cult http://www.cultofrig.com - Rigging from First Principles
 
  06 June 2013
And to answer my own question, they show the shortcut in the tooltip (baked in the command description, ARGHH), but not in the hotkey editor.
Rebinding in the hotkey editor obviously fixes it, but at the expense of the default hotkeys instead of per-window behaviour.

Oh well, it's not like I flood in artisan as frequently as I need to toggle nodes, still it was no issue in 2013.
__________________
Come, Join the Cult http://www.cultofrig.com - Rigging from First Principles
 
  06 June 2013
Sounds and looks like an unintended regression. I'll take a look when I get into the office tomorrow and see what happened there.

-s
__________________
My opinions do not represent those of my employer.
 
  06 June 2013
For what it's worth, I had the preferences from 2013 migrated over, but none of those keys were assigned or re-assigned before, so I doubt it would have interferred. At least not directly.
Thanks Shawn.
__________________
Come, Join the Cult http://www.cultofrig.com - Rigging from First Principles
 
  06 June 2013
So it would appear that these got changed over to the 1,2,3,4 hotkeys in 2014 and was an intended change for discoverability as the previous hotkeys were apparently not known by many. Let me know if that's an issue and I can get a bug in the system.
__________________
My opinions do not represent those of my employer.
 
  06 June 2013
Originally Posted by BoostAbuse: these got changed over to the 1,2,3,4 hotkeys in 2014


Aha, had been wondering about this too, those hotkeys work fine for me anyway, now that I know where they are. I usually migrate prefs too. Handy that '5' toggles node name/type too.

Cheers,
Brian
 
  06 June 2013
Originally Posted by BoostAbuse: So it would appear that these got changed over to the 1,2,3,4 hotkeys in 2014 and was an intended change for discoverability as the previous hotkeys were apparently not known by many. Let me know if that's an issue and I can get a bug in the system.

DAMN! Now I remember hearing it in a video.
I don't mind, 1234 and the old keys are all easily reached for a righty like me.
How the old ones could not be discovered is a bit puzzling as a hover would show the shortcut in the tooltip, but whatever, users are users

There is a latent mini-bug though, the shortcuts are baked in the command name, so if you hover on the buttons in the node editor with the corresponding functions you will see the old shortcuts hinted at.
That got me confused, otherwise I probably would have remembered.

Also in the hotkey editor those commands are non obvious, as when I looked for show or toggles I found the ones I re-bound, and they had no shortcut on them (and the old one baked in the name). So either non-obvious names maybe, or their shortcuts are hardbaked somewhere and don't show.

Cheers,
Raff
__________________
Come, Join the Cult http://www.cultofrig.com - Rigging from First Principles
 
  06 June 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:31 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.