Rotation order is messing with my character animation

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Display Modes
  4 Weeks Ago
Rotation order is messing with my character animation

 
  4 Weeks Ago
Hi Gang,
I'm in the middle of blocking out my character animation and I figured to change my rotation order from HPB to YXZ because my character will be jumping and spinning almost 360 degrees on the y axis. See this tutorial to better explain my reasoninghttps://vimeo.com/54541692 .So blocking is going great, the rotation order is really helping me out. I close down c4d for the day, open up the file the next morning and my posses are all screwed up. I re-do my blocking posses, save , closed out of c4d, then I open up my file and still the same thing happens and I cannot seen to recover my animation. I did however re-do my blocking again BUT with HPB as my order of rotation , save and re-open and my key posses are correct and exactly how I expected them to be.
What gives???? I would love to have this fixed because it will take forever to polish off my animation- and in Maya it seemed to work well.
Thanks in advance.
 
  4 Weeks Ago
Also, the order of rotations have only been changed for the hips, arms and feet. Thank you
 
  4 Weeks Ago
If you're using the character object to rig your character, then it is probably resetting to the rig's rotations when you restart. You might need to make the rig editable if you want to change the rotations. If you're not using the character object then I'm not sure.
 
  4 Weeks Ago
ahhh, ok, I'll make the rig editable and try then. Thanks for the advise.
 
  4 Weeks Ago
I made the rig editable and no luck, I'm still getting the same messed up results, thanks anyways tho.
 
  4 Weeks Ago
That's weird. I actually made my own custom version of the advanced rig with XYZ rotations which I load instead of the regular advanced rig. When I start animating with a rig set to XYZ I never have any issues.
 
  4 Weeks Ago
When I created my XYZ rig I had issues with the protection tags. You might also need to delete the protection tags, change the rotations, and then re-apply the protection tags.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 02:36 AM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.