How can I avoid dark areas when baking textures from overlapped models?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
Old 03 March 2014   #1
Question How can I avoid dark areas when baking textures from overlapped models?

As the title says. I made a model from some overlapped smaller parts and when I bake the shader textures from that model I get dark areas in the places where the geometry overlaps. How can I avoid such dark areas and get clean shader baked textures? To help you understand what I'm talking about I included some pics from the work window and the ambient occlusion baked map. As you can see the ambient occlusion map has black areas where the model's geometry overlap. I would like to avoid that because I'm having problems when I paint the texture in Photoshop. Thanks in advance.

 
Old 04 April 2014   #2
I think there's no way of avoiding that.
Those black areas are like a extreme level of AO because the faces are touching or very close from each other.

Those black areas will never be seen in the model, so.. there's no problem.
If they are in the way in photoshop, just tone down the channel opacity while you are working.
 
Old 04 April 2014   #3
The used images for the UV - map often don't have a homogene color. For example the upper right corner is a little darker than the corner down on the left. This is very bordering if you don't want to see seems on the models. Before I bake the image, I take care for a homogene color of my image. Also I often use the unwraped pieces as an image to find the right place for my color. It can be that I have an own image for any wraped piece that I use.
Then when everything is ready, I look for the right light settings, because the light is also baked on your image. So it can be that the models are a little bit to much lighted if I export them. But they don't have any shadows.
 
Old 04 April 2014   #4
When it comes to preventing that I think utopia780 is right. Those overlapping portions of geometry are black because AO rays can never reach those areas of the mesh. There may be a color value you can set in Blender that sets the bottom color limit from black to gray. My personal work-around for this issue is to take the AO pass into Photoshop or Gimp. Once there you can use levels & other tools to adjust the AO pass values, then just take the image back into Blender.
 
Old 04 April 2014   #5
..either way, I always edit my maps to bring up details or tone down annoying shadows.
 
Old 04 April 2014   #6
Or you model the whole thing out of one piece. So you don't have overlaps.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:14 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.