CGTalk > Software > Blender
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
Thread Tools Search this Thread Display Modes
Old 03-12-2013, 02:07 PM   #1
New Member
Join Date: Mar 2013
Posts: 4
Scale changes after bone's rotation


I'm working on a project and I'm facing some difficulties with my rigging.
When I'm rotating a child bone in "Pose Mode", my model gets deformed and the scale seems to be changing.

I already checked that my armature's scale is set to 1 on all axis.

Could you tell me what might be wrong with my rigging ?

Here's some screenshots to show you my problem:

My model without rotation:
My model after a rotation:
My armature:

Thanks for your time.
Old 03-14-2013, 01:35 PM   #2
Progressing Artist/Aminat
VoltStorm7's Avatar
Stafford Ahartz
Join Date: Jan 2013
Posts: 36
It's very strange for your rig to be doing that. Try to lock the scale in the N menu so it may not scale without notice. Try your animation a couple of times to see results and alter if needed.
Training to become a top 3-D character and creature animator
Old 03-14-2013, 02:56 PM   #3
New Member
Join Date: Mar 2013
Posts: 4
Thank you for your answer.
Unfortunately I tried to lock the scale in "Pose mode" and "Object mode" but it still doesn't work.

Some screenshots :
Old 04-01-2013, 06:30 AM   #4
New Member
BlackStormy's Avatar
Abraham Brookes
Cairns, AU
Join Date: Apr 2013
Posts: 6
That is strange. There is a way to set up constraints on bones so that moving one scales or rotates another. This is how you set up control widgets. Maybe you inadvertently did that? Have you tried to set IK up on this rig?

Check all the parenting on that bone, you might have it parenting to an odd bone that is doing that for some reason.

Also try rotating the bone then select the entire rig and press alt+s to clear the scale data of every bone. Also try alt+r to clear rotation and alt+g to clear location (transform).

If you really can't fix it, maybe you'll need to delete your rig and start again? I have had a few things with armatures that I just cannot solve and have had to go this route. I know that sucks but hey, it's all practice, right?
Old 04-01-2013, 06:30 AM   #5
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
Join Date: Sep 2003
Posts: 1,066,479
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
Thread Closed share thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Society of Digital Artists

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump

All times are GMT. The time now is 12:22 AM.

Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.