Maya 2018 - How to fix banding with Arnold?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

REPLY TO THREAD
 
Thread Tools Search this Thread Display Modes
  4 Weeks Ago
My thoughts - are you viewing from the Arnold render view?  - The default Maya render view will show banding.

If you view your render in photoshop, you'll also notice more banding, but if you view the .exr in nuke it should display smoother.  

Note:  My jpeg screenshot will show banding, becasue of the compression,  but if you look at my .tga version here:  https://www.dropbox.com/s/6h2ycnlzk...enshot.tga?dl=0

You'll probably find increasing the light strength or adding another light will help, in more normal scenes.  
__________________
AI will never achieve Human Stupidity.
 
  4 Weeks Ago
Originally Posted by Bloops: This is another scene with Arnold Area light wich also has banding in Arnoldīs final render, this one didnīt required animation, so now i can show you my banding problem with Maya 2018, maybe this helps:




Until now, no way to solve banding with Arnold 5.


This is just an undithered 8-bit image. It's what you'll see if you render to 8-bit with dithering turned off (it's enabled by default), or if you render to 16-bit or 32-bit and view it without dithering, which is what you'll see in Photoshop if you view a 32-bit image (if you convert to 8-bit it'll go away because Photoshop dithers on downconversion). This probably isn't related to the OP's issue.

But it's hard to tell what is. It's hard for anyone to help without being able to see the problem. If you can't post a video showing the problem, find a way to reproduce it in a test scene that you can post.
 
  4 Weeks Ago
Originally Posted by gfk: find a way to reproduce it in a test scene that you can post.

I already posted a test scene, 1 post ago.

Originally Posted by DeepPurple: Arnold render view?.

Nop, its not render view... itīs a final render still, my problem is banding in final renders in exr.

Originally Posted by DeepPurple: if you view the .exr in nuke it should display smoother.

Nop, Nuke shows the banding exactly the same way Maya does, i already mentioned that i checked if opening in Nuke helps, but it doesnīt.

Originally Posted by DeepPurple: increasing the light strength or adding another light will help.

Nop, it doesnīt, more banding appears as soon as i add another light in the scene and render time also multiplies.

Last edited by Bloops : 4 Weeks Ago at 11:21 AM.
 
  4 Weeks Ago
You posted an image, please post a maya project so peopeople can help you
__________________
demo videos
Close, open-relationship: C4D / Zbrush
Hate / love: Maya / Houdini
Former gf: XSI
 
  4 Weeks Ago
The dithering is nothing else but a display problem. The image itself is okay. Did you notice how the banding changes if you modify the exposure/gamma settings? This would not happen the final image contains the banding. I tried to modify the image in photoshop to increase the banding but I completly failed, so the image is okay, the banding is a display problem.
__________________
www.renderwiki.com - www.openmaya.net
 
  4 Weeks Ago
Originally Posted by Bloops: I already posted a test scene, 1 post ago.


Nop, its not render view... itīs a final render still, my problem is banding in final renders in exr.


Nop, Nuke shows the banding exactly the same way Maya does, i already mentioned that i checked if opening in Nuke helps, but it doesnīt.


Nop, it doesnīt, more banding appears as soon as i add another light in the scene and render time also multiplies.

I rendered the scene, loaded the EXR in Photoshop and converted to 8-bit and there was no banding at all.  DP is viewing the same thing in Nuke with no banding.  You need to make an effort to figure out what you're doing differently, and not just reply "nope nope nope nope".
 
  4 Weeks Ago
Originally Posted by haggi: The dithering is nothing else but a display problem. The image itself is okay. Did you notice how the banding changes if you modify the exposure/gamma settings? This would not happen the final image contains the banding. I tried to modify the image in photoshop to increase the banding but I completly failed, so the image is okay, the banding is a display problem.

I already tested the exr in 3 diferent displays, also in my cellphone, i dont think 4 displays (2 brand new) wont work with Maya 2018 and Arnold 5... even the still i posted here has banding and other ussers already confirmed they also see the banding of the picture in their displays, its not just my displays.

I tested all output configurations, included gamma, all them show banding, the only thing that changes is the strenght of the colors, if i change to gamma workflow the colors become stronger, i generally dont use this because colors sometimes look unreal strong in gamma, but it didnīt fix my banding either, i wish it did.

i dont know if i can fix banding in Nuke the same way i would do in Photoshop, i dont even have photoshop..... its not that i want to fix an still, i want to fix a complete scene with more than 250 stills and i dont think i can fix banding of 250 exr stills in photoshop, i always send my exr to Nuke, there is were i fix any other thing wrong with my animations, like noise or colors...but i have no idea how to fix Banding with Nuke.

If i modify the exposure, the scene becomes lighter with an stronger kind of light, my light is exactly the way i wanted, its not pretended to be lighter but a bit darker, because its supposed to be at night, now to fix banding i have to make my night bright as day? i dont think so, it wont work because my original scene starts dark and light intensity starts to raise in about 5 to 7 seconds, this raising is what mostly shows this horrible banding waves, If i raise light from start....then the original concept is gone for the sake of solving Arnolds banding!

Last edited by Bloops : 4 Weeks Ago at 10:40 PM.
 
  4 Weeks Ago
Originally Posted by luisRiera: You posted an image, please post a maya project so peopeople can help you

I already posted a test scene 2 posts ago, the scene is called "banding" please check it, maybe you can help..... just to be clear i dont want to fix a single still with banding.... i want to fix 250 stills to 500 all with banding, im doing animation, and i dont have photoshop, because i dont use photoshop to post animations...

If i fix this animation it has to be in Maya, or all my work is going to have banding forever, as a last resource i might fix it in Nuke, still donīt know how.

if i can fix dithering in Maya? i dont know i will start to investigate how to change dithering in Maya, i never did that..

Here i repost the scene: Banding scene

Last edited by Bloops : 4 Weeks Ago at 10:42 PM.
 
  4 Weeks Ago
The screenshot posted a few replies above looks quite alright to me, well inside the limits of what any other renderer would output.
__________________
..je suis -L -S -D!
 
  4 Weeks Ago
Let's see if I understand the issue...;
So, this image:



Is the SAME as this one?:



Because they both seem to be completely different. One with banding, one without. O_o
__________________
3D Animator and TD at www.vortice3d.com

"Donīt trust on affemeral things, only love will last..."

Visit my BLOG: 3djoie.blogspot.com
 
  4 Weeks Ago
I think the problem is related to 8bit monitor. On grayscale a 8bit monitor can display 2^8 = 256 gray value. This kind of banding affecting Photoshop gradient too for example.
Can be interesting make some test on 10bit displays.
__________________
May9 Pro a new Maya user experience.
 
  3 Weeks Ago
Originally Posted by joie: Because they both seem to be completely different. One with banding, one without. O_o

Actually i do see a bit of banding on your images too and i tested watching your stills also in several displays and also in my cellphone just to be sure... banding its less notorious but images are smaller too... maybe im too picky about quality.

Originally Posted by indrema: I think the problem is related to 8bit monitor. On grayscale a 8bit monitor can display 2^8 = 256 gray value. 
Thanks man, the test scene is done with grayscale colors, but my actual scenes are full in color and texture, but i canot upload those scenes (250 megas each), thatīs why i made a test scene, the grayscale selection was done randomly; my real problem is in my original scenes and i didnīt noticed the banding in those scenes until i made an animation of a light increasing its intensity, then large waves of banding started to move across every flat surface.

I couldnīt find a solution to my banding problem with Maya 2018 and Arnold, i already tried even to create an ai physical sky with 4 ai photometric lights and iīm still getting banding after rendering in exr (now it appears in the sky obj as horizontal lines) tested in 3 displays plus my cellphone and this time also in my tv, i tried adding noise, multiple lights, more exposure, more samples, several render configurations, itīs my 3° test scene that produces banding.

Autodesk Maya 2018/Arnold vs Banding = Banding Wins... by KO! in third round.

So,

How to fix banding on Nuke Studio 10 for animation stills in exr?

Last edited by Bloops : 2 Weeks Ago at 02:46 AM.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright Đ2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:47 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.