Compiling Qt 4.7.1 error

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2013   #1
Compiling Qt 4.7.1 error

Hi, I'm trying to compile Autodesk's modified Qt 4.7.1 for Maya 2012 Sp2. In VS Command Prompt, I ran the
C\qt-adsk-4.7.1> configure -platform win32-msvc2008 -release -no-qt3support
and it configured successfully. Then I typed nmake in the VS command prompt and it compiled for 6 hours and stopped at this error:

mt.exe : general error c101008d: Failed to write the updated manifest to the resource of file "..\..\..\bin\dumpcpp.exe". The process cannot access the file because it is being used by another process.
NMAKE : fatal error U1077: "C:\ProgramFiles SDKs\Windows\v6.0A\bin\mt.exe" : return code '0x2'


Please please someone help. I've tried the the 6 hour compile session twice now.
 
Old 02 February 2013   #2
One of the possible causes of this error is anti-virus software. Try disabling it before compiling.

I've tried the the 6 hour compile session twice now.

Use jom instead of nmake for compiling Qt. With jom you can specify the number of cores to use in the build process. Basically you can max out your machine resulting in a significantly shorter build time.

jom download (qt-project.org)

ChrisZ
 
Old 02 February 2013   #3
tried it

Originally Posted by zeroeffect: One of the possible causes of this error is anti-virus software. Try disabling it before compiling.
ChrisZ

hey zeroeffect. Yup, I tried it. Same result. The Autodesk instructions ask you to download Qt from this link: http://get.qt.nokia.com/qtsdk/qt-sd...rce-2010.05.exe

The link does not respond so I downloaded Qt from here: ftp://ftp.qt-project.org/qt/source/qt-win-opensource-4.7.1-vs2008.exe

Do you know what the difference between the 2 files is? And would you happen to have the qt-sdk-win-opensource-2010.05.exe file somewhere?
 
Old 02 February 2013   #4
I believe you should be safe with that version but I can't tell you what the difference between the two files is. Unfortunately, I don't have the the original file specified by Autodesk (I think I used the same one you currently have).
 
Old 02 February 2013   #5
thanks zeroeffect. Got home today to find the sdk finally compiled without error. I created PATH variables to the C:\Qt, C:\Qt\bin, C:\qt-sdk-4.7.1, C:\qt-sdk-4.7.1\bin directories and that finally did the job.
 
Old 02 February 2013   #6
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 04:53 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.