CGTalk > Software > Autodesk Maya
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 01-30-2013, 11:00 PM   #1
Beacons
New Member
portfolio
Alex
Uhm, United Kingdom
 
Join Date: Jan 2013
Posts: 2
Exclamation Blurry textures causing problems

Hey guys, I'm trying to create some geometry for use in S.T.A.L.K.E.R. Call Of Pripyat, and to do so I'm using Maya 2011 64bit with a community made plugin for the engine, known as X-Ray. The official plugins aren't supported for anything beyond about Maya 8.5 and I don't have access to it :( Anyway, it all works fine up until I try to start texturing my objects.

http://scr.hu/0fu0/0mozi

Here you can see two materials, XRayMtl1 and Lambert1, both have the same texture applied.
This is what it looks like with the Lambert material applied:

http://scr.hu/0fu0/zg6wv

and this is with the XRayMtl material:

http://scr.hu/0fu0/pjg2y
I have no idea what's going on here. On objects imported from the game, the textures look perfect, and materials that already exist can be assigned just fine.
When using a new texture (and hence creating a new material) however, it spawns as this blurry mess.
As well as this, duplicating a perfectly-working material that was imported instantly makes it into a blurry mess as soon as I try and apply it to an object. There are no differences that I can see in the AE between either material...

I'm hoping one of you Maya geniuses could possibly help me out, I'd really appreciate it.
 
Old 01-31-2013, 08:34 PM   #2
InfernalDarkness
Madness. Madness, I say!
 
InfernalDarkness's Avatar
portfolio
Sho Pi
CG arch/viz
Seattle, USA
 
Join Date: May 2008
Posts: 5,772
This is a Viewport issue, really. You'll see the same effect if you (for example) apply any of the 3D Maya textures, such a Marble or Granite or anything like that. The old Maya viewport doesn't know how to draw these kinds of procedurals very well, so you get a weak approximation of them instead.

I skipped Maya 2011 myself, but you should have Viewport 2 as an option. In your viewport, click "Renderer" up top and pick "Viewport 2.0" and see how it looks then?
__________________
Commodore 64 @ 1MHz
64KB RAM
1541 Floppy Drive


"Like stone we battle the wind... Beat down and strangle the rains..."
 
Old 01-31-2013, 09:28 PM   #3
Beacons
New Member
portfolio
Alex
Uhm, United Kingdom
 
Join Date: Jan 2013
Posts: 2
Quote:
Originally Posted by InfernalDarkness
This is a Viewport issue, really. You'll see the same effect if you (for example) apply any of the 3D Maya textures, such a Marble or Granite or anything like that. The old Maya viewport doesn't know how to draw these kinds of procedurals very well, so you get a weak approximation of them instead.

I skipped Maya 2011 myself, but you should have Viewport 2 as an option. In your viewport, click "Renderer" up top and pick "Viewport 2.0" and see how it looks then?


Thanks for your reply.

Firstly, apparently my GTX 670 doesn't support Viewport 2.0...

Secondly, the textures look perfect on imported objects or when applying a material that already exists in the scene (one that was imported on an object), so how can that be?
 
Old 02-01-2013, 07:47 AM   #4
fleabay
Attribute Editor
portfolio
Puddin' Tane
USA
 
Join Date: Jan 2013
Posts: 334
Choose both materials (1 good, 1 blurry) from the hypershader, go to Window-General Editors-Attribute Spread Sheet
Choose the All tab.
Compare all the attributes and see if any are different. Make changes to the blurry one.

If that doesn't fix it, choose 2 textures from the hypershader textures tab and compare those.

Still no? Try the viewport Shading menu - Hardware texturing - options. Just click Apply first and see if that fixes it. Play with the options and see if you can get a good result.
 
Old 02-01-2013, 07:47 AM   #5
CGTalk Moderation
Expert
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,478
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:42 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.