CGTalk > Software > Maxon Cinema 4D
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 12-24-2013, 08:09 PM   #1
chasecanade
Frequenter
portfolio
chase canadé
USA
 
Join Date: Nov 2013
Posts: 129
Question Mesh Lines showing up in Render and Mesh Split when adding HyperNurbs

Hi -

Sorry to bother you guys with this.

Two issues.

I've created some meshs - they're clean. Checked them over.

When adding HyperNurbs - they are splitting apart and showing a seam on a couple of them.

Take the mesh out of HyperNurbs and it's fine - no break or separation.

As stated I checked the points where it's showing up, but - can't figure out how to fix it since it is not showing up broken until adding it back into hyperNurbs.

Second question:

I'm adding the meshes to HyperNurbs to get them to smooth out and render perfect. But no matter how many subdivisions I add. (I've added enough to turn the mesh solid white) It still shows mesh lines through the texture in the render. especially on close ups.

I've rendered a subdivided primitive right along side my mesh they render fine, nice and smooth.

I'm not using a image texture - just stock colors in C4D for the moment - glossy paint or glass materials.

I did do a search - and found a related post but - I don't have the same problem I feel.
I'm haven't added any lights in the scene yet. Just the default light.
I haven't made any real textures or UV mapped textures.

any thoughts?

I can render out and provide some stills if needed of both issues if that will help explain the problem. (didn't come with any today)

tia
chase
 
Old 12-24-2013, 08:21 PM   #2
AdamT
oh ... what?
 
AdamT's Avatar
Adam Trachtenberg
Modeler, Animator, Attorney
3D Anvil
Miami, USA
 
Join Date: Jun 2002
Posts: 10,516
I'm guessing that these are imported meshes? Anyway, it sounds like you have two problems:

1. separation: this is probably the result of unwelded vertices. You wouldn't be able to see the problem in the unsmoothed mesh if the vertices are overlapping. To fix it, run the Mesh>Commands>Optimize command. That will weld any points within the set tolerance distance;

2. faceting: this is the result of not having a phong tag on your object, or of having a phong tag with improper settings. Solution: give your mesh object a phong tag. You'll probably want to check the tag's "angle limit" box. The default angle of 80 degrees usually works, but you may need to lower it depending on the mesh.
 
Old 12-24-2013, 09:04 PM   #3
chasecanade
Frequenter
portfolio
chase canadé
USA
 
Join Date: Nov 2013
Posts: 129
Wow! Thanks for the fast reply Adam.

Quote:
Originally Posted by AdamT
I'm guessing that these are imported meshes?...


Actually no - all created in C4D. (I'm experimenting.)

Quote:
Originally Posted by AdamT
Anyway, it sounds like you have two problems:

1. separation: this is probably the result of unwelded vertices. You wouldn't be able to see the problem in the unsmoothed mesh if the vertices are overlapping. To fix it, run the Mesh>Commands>Optimize command. That will weld any points within the set tolerance distance;


Okay I'll give that a shot. Though I had tried selecting the individual point(s) that were giving an issue and clicking weld after removing it from the HyperNurbs, but it didn't do anything. I'll try Optimize.

Quote:
Originally Posted by AdamT
2. faceting: this is the result of not having a phong tag on your object, or of having a phong tag with improper settings. Solution: give your mesh object a phong tag. You'll probably want to check the tag's "angle limit" box. The default angle of 80 degrees usually works, but you may need to lower it depending on the mesh.


The phong tag... I didn't think to even look for it. lol.
I knew it would have to be something simple.

Again Adam, Thankyou for the quick reply, I was just fixing to head home.

Happy Holidays to you and yours,

- chase -
 
Old 12-24-2013, 09:04 PM   #4
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,480
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:27 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.