Vray for Maya distributed rendering

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  03 March 2012
Vray for Maya distributed rendering

Hello,

i got one Master machine and 3 slave nodes. When i start a distributed rendering via command line from my master machine, the 3 slave nodes are rendering. But when i start a job via vommand line from a slave machine, just the one slave is rendering. And the others are staying idle.
All machines have rights to access each other.

Hope you guys can help me!
Best regards, Chris


SOLVED! For those who ran into the same problem:

on every machine you want to start a distributed rendering you must have run a backburner job one time. Like its stated in the docs : "... you will need run at least one Backburner job with this machine as a server, before you can use the machine for distributed rendering."

Last edited by stromberg : 03 March 2012 at 04:47 PM.
 
  03 March 2012
you can enable DR rendering either by saving the file with the DR rendering set to on or just by adding this preRender command to your command line command:

render -r vray -preRender "setAttr \"vraySettings.sys_distributed_rendering_on\" 1;" /Users/beige/Desktop/test.ma 


That will enable it even if the flag is off.
 
  03 March 2012
great...its possible to set the slaves` IP-adresses in the same command? so i can chose which slave shell render and which not?
 
  03 March 2012
My scripting knowledge in mel is pretty basic, but I know that when you go into the settings for distributed rendering, you're calling up a file called vrayDR.mel in your maya/vray/scripts folder.

If you play around in that, there's a process called vrayAddServer which goes through and calls up vraySaveServersInfo when you add a server. vraySaveServersInfo then goes though and calls up vrayWriteServers and vrayWriteServerStatus.

Those last 2 processes save a temp file in your directory of addresses and statuses...

so I don't have much time currently to play around with it, but perhaps try adding the IPs to that server_list.tmp file and put enable in the server_status.tmp file.

I am sure there's an easier way to add this through either mel or python, but I don't have the time currently to play around... perhaps Dave can shed some light (or even Vlado if he finds this)
 
  03 March 2012
Thx for your hint. There are several good inputs i can work with. I will try this the next days and keep you informed.
 
  10 October 2012
Vray Render Slave with maya 2012

i'm have an issue where i'm rendering using 2 render nodes but the processors aren
t responding to the master when i look in the performance tab of the task menu, they respond to the master computer in the sense that they load all the necessary textures, but they get to a point in the render where it takes up to 4 house to try and finish a render do you have any suggestion....
 
  10 October 2012
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:19 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.