Got a problem with trying to move my ik spline rig with a global controller.

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
  02 February 2014
Got a problem with trying to move my ik spline rig with a global controller.

(First time posting, thought I made another post, but I can't seem to find it. Not sure if it was deleted or didn't post for some reason.)

So I made an ik spline rig for a squid, each tentacle has an ik spline in it, and each vertex of the curve is a cluster. Each cluster is point constrained to an individual controller.

It works fine in place, and I can move the rig and mesh alone, and the controllers still function as long as they remain in their original positions in the scene. But if I try to move them with the mesh and rig, the rig freaks out.

I've taken screen shots and linked them below.

http://i60.tinypic.com/2v3lws8.png

http://i59.tinypic.com/13yib0k.png

http://i59.tinypic.com/16m0jf4.png

I'm thinking there might be a problem with conflicting parenting or constraints, but this is my first time using a rig with cluster based controllers.

Any advice would be appreciated.
 
  03 March 2014
I am new to maya and just had the exact same problem you describe. I wanted to rig a ball and chain with an ik spline handle. By pressing shift P to unparent the controller got things working agin. I think I may have also tried to delete any constraints I placed on the controller accidentally. Anyhow they are things you can try.
__________________
The terminal velocity of individual particles is directly related to pink rabbits on a bank holiday.
Characters, Games, Toys
 
  03 March 2014
Probably some double transformations on the splines. Make sure you uncheck inherit transformation on the transform node of the splines. This should probably solve the problem.

Hope this helps. Good luck!

Ralph
 
  03 March 2014
Originally Posted by ralphymeijer: Probably some double transformations on the splines. Make sure you uncheck inherit transformation on the transform node of the splines. This should probably solve the problem.


QFT, you are already transforming all the CV's in the iksplines so if the curve is under a global controller that is also moving the cluster then you'll get a double transformation.

I typically have a group in my rig hiearchy called noxform that I put all transforms that I don't want to transform
__________________
blah blah blah
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:29 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.