Wavy UV's when smoothing with the crease tool.

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

Thread Tools Search this Thread Display Modes
Old 09 September 2012   #1
Wavy UV's when smoothing with the crease tool.


I've been looking for a solution to this all day and haven't had much luck. Hopefully someone here has encountered this.

Essentially I am trying to use the crease tool in Maya. I'm familiar with adding in supporting edges for sub-d modelling but I'm quite interested in trying our a new workflow. Everything has been working fine up to this point, but when I try to smooth I am getting issues with the UV's. I've linked to a picture below. All of the edges that I have set to 'crease' when smoothed appear wavy.

Anyone have a solution? For my test to work I need to let the UV's smooth, so turning off smooth isn't an option. Also, although I can fix a single piece manually, to incorporate this into a pipeline I need it to work on all of my geometry.

If you have an ideas I am all ears!

Old 09 September 2012   #2
Yo dude, I have just tested this on a new piece of geo and on some clothing on one of the models here at work with varying levels of crease with the crease tool and I am getting no weird problems like you when smoothing. We are using maya 2011.5 here at work.
Website http://jorel-latraille.com
Old 09 September 2012   #3
As a work around you could possibly duplicate the geo, smooth both, do the crease on one then transfer nice smoothed UVs onto the creased version. This could be scripted to save time
Website http://jorel-latraille.com
Old 09 September 2012   #4

I'm using Maya 2012, I have a rough work around of doing the smoothing in Mudbox instead, if you set the environment variables you can get the border edges smoothing like it does in 2010.

No joy in Maya though, what kind of objects are you smoothing, straight lines or curves? I can get it working if I transfer etc.. but even scripted I don't think it will be as straightforward as I need it to be. I'll try 2011 instead and let you know.
Old 09 September 2012   #5
Jorel, when you tried it out have you checked the UV's in smooth preview?
Old 09 September 2012   #6
yo, I am doing it on curves and straights, tried it on a bit of everything. I have Smooth UVs ticked in Smooth Options and I am doing it by 1 and 2 lvls in exponential smooth. Not getting the kind of results you are getting.
Website http://jorel-latraille.com
Old 09 September 2012   #7
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
Thread Closed share thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Society of Digital Artists

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump

All times are GMT. The time now is 06:10 PM.

Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.