CGTalk > Software > Autodesk Maya
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 01-08-2013, 03:06 PM   #1
splinta
PRO
portfolio
Guy Schuleman
3D Generalist
Sinister Studio
Sandton, South Africa
 
Join Date: May 2006
Posts: 97
File will not open

Hi all

I have a scene file done in Maya 2011 and it will open but is completely empty. I can import the file into a new scene and all the contents come with. But once I save it and try to reopen, it is empty again. I get the following messages in the script editor:

Code:
file -f -options "v=0" -typ "mayaBinary" -o "D:/WORK/maya/scenes/chocoBar_2013/chocoBar_v03_bubbleOn.mb";addRecentFile("D:/WORK/maya/scenes/chocoBar_2013/chocoBar_v03_bubbleOn.mb", "mayaBinary"); // File read in 0 seconds. // // Warning: swatches file depend node not found, icon discarded: chocolateVR // // Warning: swatches file depend node not found, icon discarded: file2 // // Warning: swatches file depend node not found, icon discarded: VRayDirt1 // // Warning: swatches file depend node not found, icon discarded: labelPlayBlastM // // Warning: swatches file depend node not found, icon discarded: emitionM // // Warning: swatches file depend node not found, icon discarded: file5 // // Warning: swatches file depend node not found, icon discarded: ramp4 // // Warning: swatches file depend node not found, icon discarded: npPointsVolume // // Warning: swatches file depend node not found, icon discarded: wrapper2SidedVR // // Warning: swatches file depend node not found, icon discarded: file4 // // Warning: swatches file depend node not found, icon discarded: file6 // // Warning: swatches file depend node not found, icon discarded: wrapperVR // // Warning: swatches file depend node not found, icon discarded: foilVR // // Warning: swatches file depend node not found, icon discarded: file3 // // Warning: swatches file depend node not found, icon discarded: npPointsBlinn // // Warning: swatches file depend node not found, icon discarded: chocolate_bubblesVR // // Warning: swatches file depend node not found, icon discarded: pPlane1_vrayLightMeshProperties // // Warning: swatches file depend node not found, icon discarded: file1 // // Error: Object 'EEexprNameT' not found. //


Everything marked with "VR" is a Vray mat.

Can anybody help please. I have no idea what is going on.
 
Old 01-08-2013, 04:06 PM   #2
Panupat
Expert
 
Panupat's Avatar
portfolio
Panupat Chong
Thailand
 
Join Date: Feb 2004
Posts: 1,942
I remember seeing similar errors when our studio used cgfx shader. We got it working by saving the file as mb instead of ma... Never had it happen with Vray before so I'm not sure.
 
Old 01-09-2013, 07:03 AM   #3
splinta
PRO
portfolio
Guy Schuleman
3D Generalist
Sinister Studio
Sandton, South Africa
 
Join Date: May 2006
Posts: 97
Thanks for the reply. I'm not using cgfx shader. It isn't even loaded and the file is saved as .mb already.

But if you say that it is a shader issue that you had, it might help to narrow the problem down.

The errors point to the swatches not loading but I dont see how they wouldn't?
Any clue what 'EEeprNameT' is all about?
 
Old 01-09-2013, 08:39 AM   #4
Panupat
Expert
 
Panupat's Avatar
portfolio
Panupat Chong
Thailand
 
Join Date: Feb 2004
Posts: 1,942
that EEeprNameT error is about the expression editor UI. I don't think you need to worry about it.

http://forums.cgsociety.org/archive.../t-1017319.html

I think the swatches should be able to rebuild themselves when you open hypershade. Setting project directory might help load the original ones.

Look in your outliner or hypergraph, your original model may still be there and selectable. If you can select it, try to export selection and import into new scene. The model might also show up in the view port as transparent wireframe once selected.

Last edited by Panupat : 01-09-2013 at 08:46 AM.
 
Old 01-09-2013, 11:59 AM   #5
splinta
PRO
portfolio
Guy Schuleman
3D Generalist
Sinister Studio
Sandton, South Africa
 
Join Date: May 2006
Posts: 97
Quote:
Originally Posted by Panupat
that EEeprNameT error is about the expression editor UI. I don't think you need to worry about it.

http://forums.cgsociety.org/archive.../t-1017319.html

I think the swatches should be able to rebuild themselves when you open hypershade. Setting project directory might help load the original ones.

Look in your outliner or hypergraph, your original model may still be there and selectable. If you can select it, try to export selection and import into new scene. The model might also show up in the view port as transparent wireframe once selected.


Thanks Panupat, unfortunately there is nothing in the scene that opens. the title bar says im in the file but nothing is there. Not in the hypershade or even outline with show DAG off. But the file size shows me that there is something in it and if I import it onto a clean scene everything comes with. Its the reopening I think is the problem.

after some fiddling, I think I have figured it out.

Last thing I remembered doing to my file was upping my texture resolution for a playblast. Connected a texture to a lambert and set hardware texturing up to 256 x 256. This wasn't enough so on the file node was an extra resolution input to enter a value. Once I entered 1024 for example, all the problems started happening.

The same "EEeprNameT" error started to come up when I opened my file etc.

Have you experienced any bugs with this resolution attribute before?
 
Old 01-09-2013, 11:59 AM   #6
CGTalk Moderation
Expert
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,478
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:54 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.