How to remove all nearby green paint from red paint in weight paint mode from a model

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
  09 September 2017
How to remove all nearby green paint from red paint in weight paint mode from a model













I looked and looked online, it's like no one ever solved this question before. So good luck everyone.




I want only the red area, none of that green stuff. So I can have multiple particle hair systems on a model in blender. It's either that or finding some way to have particle hair inside the selected vertices. For some reason, they also like to pop up along the fading lines of the selected vertices. Is there any way to fix this without manually cutting hairs from the model? ( I don't know how to delete hairs one by one, which also would be useful to know.)
Anyone got any helpful ideas? Thank you for your time.


Quick facts:


I want the eyebrow hair along the red on the models face. This is the main concern.


Some of the vertices cross over , for example. The Eye brow and the full body vertex groups. The full body vertex group also contains the eyebrow vertex group. It is there so I can apply the skin pic material to the whole body.


No matter what I do I get 3 outcomes.


Fat eyebrow that goes outside my vertex groups. ( maybe because of the fading lines leading outward from the selected vertices.)


Crazy hair all over the place.


Or nothing.


So manually deleting each strand is an option as well.


I just to have multiple particle hair system of different lengths on my model.


Any help would be greatly appreciated. Thank you for your time.

Here are links with the rest of the images, hope it helps.
Both links show the same images.
http://forums.cgsociety.org/showthr...622#post8336622
https://blenderartists.org/forum/sh...308#post3235308

Last edited by RockinFoxxis : 09 September 2017 at 06:31 AM. Reason: to add more info
 
  3 Weeks Ago
Hey RockinFoxxis, right under weight tools is the clean button. Once you click it (with your current "eyebrows" group selected, as it is in your picture) you will see options where in your first picture is says "weight paint mode". Make sure that "Active Group" is selected, and below it is a slider with a number from 0 to 1. This is the threshold at which a vertex is removed from the group. In this case you can move it to around 0.8 or 0.9 and you should see all the green painted vertices turn blue, and the red remain. Cheers!
__________________
"You may only get one chance, make sure you take it."
 
  2 Weeks Ago
Thanks everyone for your help. The problem is solved.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:10 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.