Solved an "Error: line 0: Error reading file." for a .mb file (it may help somebody)

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 09 September 2013   #1
Solved an "Error: line 0: Error reading file." for a .mb file (it may help somebody)

Nearly screwed myself today.... maybe this can help others in the future. Did it by fluke:

Error: line 0: Error reading file for a .mb file.

Maya runs something like this when you choose a simple File>Open:

file -f -options "v=0;" -typ "mayaBinary" -o "K:/test.mb"; addRecentFile("K:/test.mb", "mayaBinary");

Just copy and paste from the script editor but delete:

-typ "mayaBinary"

so it's:

file -f -options "v=0;" -o "K:/test.mb"; addRecentFile("K:/test.mb", "mayaBinary");

-------

Alternatively the equivelant with File>Import:

file -import -type "mayaBinary" -ra true -mergeNamespacesOnClash false -rpr "test" -options "v=0;" -loadReferenceDepth "all" "K:/test.mb";

Copy and Paste it into the script editor, but delete -type "mayaBinary":
so:

file -import -ra true -mergeNamespacesOnClash false -rpr "test" -options "v=0;" -loadReferenceDepth "all" "K:/test.mb";

Hope this helps
 
Old 09 September 2013   #2
Nice tip. It would be interesting to know what actually causes that error in the first place...
 
Old 09 September 2013   #3
or try save scene as .ma edit with txt editor and see whats is say in line 0

Last edited by bazuka : 09 September 2013 at 05:59 AM.
 
Old 09 September 2013   #4
Yeah i know... Normally I do save as .ma.
 
Old 09 September 2013   #5
i just came across this the other night whilst searching for something else and tonight this happened to me but unfortunately didn't help. I actually then got Error Line1 after trying it.
Thanks for the tip though. Might be more successful on a different file.
__________________

 
Old 09 September 2013   #6
Very interesting, thanks!
__________________
My blog (fr)
 
Old 09 September 2013   #7
maybe the file was named .mb but it was actually a maya ascii file?
 
Old 09 September 2013   #8
Originally Posted by lucericr: maybe the file was named .mb but it was actually a maya ascii file?


nope. i checked beforehand.
 
Old 09 September 2013   #9
I pretty much always save as ascii but since the file size is so large I've had to use mb and i have instances in my scene which I'm sure have stuffed something up because if i rearrange my groups in my scene is causes my scene get corrupt and when reopening it all my geo is missing.
lost a couple hours last night and this morning trying to get it to work.
i get an error saying can't ungroup or group. really painful. I do not like a messy heirachy in my files.
__________________

 
Old 09 September 2013   #10
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:35 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.