Can't seem to export an animated character as .fbx :|

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 06 June 2013   #1
Exclamation Can't seem to export an animated character as .fbx :|

I'm getting sooooooooooo fed up with this ('scuse the french) BULLSHIT.

So, I have a character set up with advancedSkeleton, referenced into a separate file where I've keyframed the animations it's supposed to have. It's all done, the animations are perfect. Exporting it, however, seems to be an impossible task for some arcane reason. I've watched several tutorials of people and followed their actions literally second by second, doing the exact same things they do, but my character mesh just won't export! *Pulls hair*
I don't know what kind of black magic they were using, if the fbxmaya plugin requires the sacrifice of a virgin and/or the offering of your firstborn to cooperate, but I just CAN'T seem to get it to work at all.

First, I tried just selecting the character mesh and doing Export Selected with the options described here: http://wiki.etc.cmu.edu/unity3d/ind...g_Models_(Maya)
The exported file was empty.

Secondly, I tried Export All with the same options. The entire rig, complete with animations, was exported. The mesh wasn't.

Thirdly, I tried baking the keys using Edit > Keys > Bake Simulation on the joints. No dice, the mesh still wouldn't be exported.

I'm at the uttermost tip of the end of my rope here. Please help me before I'll have to commit myself to the local asylum! >.<
 
Old 06 June 2013   #2
Did you click the checkbox to export deforming geometry?
__________________
blah blah blah
 
Old 06 June 2013   #3
Yep, of course.
 
Old 06 June 2013   #4
I've tried every conceivable variation of options in fbx exporter, and my mesh just keeps on disappearing while exporting. Which leads me to the unavoidable conclussion - There must be something wrong with the mesh itself rather than with the fbx exporter.

It's weird though. I started over from a blank slate, using the earliest .obj I had of the character mesh as a starting point, and redid the rigging and skinning. Still ended up with the same result. But the mesh can't be at fault when it's coming directly from a .obj, right? I mean, it can't have any attached hidden nodes that would make the mesh impossible to export then, right?
 
Old 06 June 2013   #5
Try merge vertices with tolerance of 0.01. Try merge border edges. Try an older version of fbx?

Does it import into maya ok? What if you import into maya after exporting with no animation?
 
Old 06 June 2013   #6
None of those things made any difference :(
 
Old 06 June 2013   #7
Have you also checked the bake complex checkbox? If the animation data is on AdvancedSkeleton and you're trying to output just the skeleton data then that skeleton data has no keys, it's driven..
__________________
Founder & CEO : Red9Consultancy
Red9 StudioPack : Red9 StudioPack GitHub
Author: Autodesk Masterclass 2011 - 'Live Animation Binding'
 
Old 06 June 2013   #8
I baked the animation to the joints before exporting. And, as said, the mesh isn't just not getting animated in the exported file, it's completely gone when I open it up. The skeleton is still there performing the animations.

I also tried to export just the character mesh as an obj, to test that. I got this error message:

"Your OBJ file contains faces shared by multiple groups. Maya cannot create multiple objects for this file. A single mesh object will be created instead. The OBJ group information will be captured in Maya sets."

I have no idea why this happens tbh. Fair enough, it's not one contiguous mesh (they eyes are not welded with the eyelids) but I didn't get that error message when I imported the OBJ into the file to rig in the first place, and the mesh hasn't changed since then. So, kinda odd. Still, it's an error... So could that have anything to do with my mesh disappearing when exporting as .fbx?
 
Old 06 June 2013   #9
Screw it. Here's the file. Hopefully someone can make heads or tails of what's wrong with the mesh.

http://www.2shared.com/file/i6t6AM9..._collectio.html
 
Old 06 June 2013   #10
I discovered something more. The transform node of my mesh is replaced by a FosterParent node. Could that be what's messing it up for me? And if so, how do I make a new transform node and replace that FosterParent node?
 
Old 06 June 2013   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:33 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.