OpenSource Maya Toolbox

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Display Modes
  02 February 2006
Jacob,

Well there are still issues.

When I attempt to close maya after the installation but without having otherwise used the file it asks if I want to save the changes (the om toolbox addition). When I clicked yes I am told that changes couldn't be saved because it doesn't have write support.

When reopening maya omtoolbox was not installed and I had to again open the installer etc to have it available. (Rather an inconvenience)

Another issue is that due to the amount of data in the maya menu bar there is very little room at the end for the mac stuff normally on the bar. Thus, even after reinstalling it omtoolbox didn't show in the menubar until I clicked on the menubar. Perhaps this is one of the reasons mac users don't see it after installation. It might be there but not visable.

Robert
 
  02 February 2006
roberte:
Ohh.. so close to some resolution...
Can only say it again.. I have no clue how OSX works, and clearly it differs from windows and linux on this point.
I'm really helpless with this one, and as much as I hate to sit and watch, I can't help anymore.
And as far as I can see, I can't gain access to Maya on a Mac anywhere I know of here in Denmark to test it myself :(
I'm very sorry...

Cartesius:
You need to add the OMT section to your userSetup.mel
Concerning the installer and you being on a windows machine, it should be working perfectly. Havn't experienced any issues before.
You are using OMT v. 0.5.1 right?
and did you write the following line into the installers text field?
 C:\Documents and Settings\anders.kjellberg\My Documents\omtoolbox 
__________________
- http://www.jakob.welner.dk - OMToolbox - PAIE -
 
  02 February 2006
Jacob,

Oh well, at least it works (with a bit of work around) eventually someone will be able to figure it out.

In the mean time, thank you for all the effort you have put into this project! It is greatly appreciated!

Robert
 
  02 February 2006
Sorry if I haven't read through all the pages, but if you are having a problem on the Mac and you have specific questions about how things work then I might be able to help.
If you could summarize your problems in one post then I could take a look. I sit beside the guy who is mostly resonsible for UI/workflow issues on Maya and he is a Mac-freak so if there are Mac specific questions then he would be able to answer them.


Although questions like "Why is Windows case insensitive and the Mac case sensitive" will likely be answered with "That's just the way it is".
 
  02 February 2006
Originally Posted by JakobWelner: Cartesius:
You need to add the OMT section to your userSetup.mel
Concerning the installer and you being on a windows machine, it should be working perfectly. Havn't experienced any issues before.
You are using OMT v. 0.5.1 right?
and did you write the following line into the installers text field?
 C:\Documents and Settings\anders.kjellberg\My Documents\omtoolbox 


Thanks, I'll go through the installation process once again as soon as possible and report what happens! (I think I missed the part of adding the OMT to my userSetup.mel.)

/Anders
__________________
dogday-design.se
 
  02 February 2006
Hey goleafsgo.
I can try to explain the matter as best as possible, though I suspect the actual error being a simple typo or something like it, but there's plenty of possibilities

It started with the error: "line 1: Cannot find procedure "OMT_toolboxMenu";" which suggests that the module file isn't properly configures, as the path to this OMT_toolboxMenu is added through the module.
So, after having set this up properly and run the installer script, everything seemed to work.
By closing Maya now, a prompt appeared asking to "save the changes" (I have never experienced such a prompt when having added only extra script pathes??!)
Clicking "yes" results in an error claiming no write support.
When reopening Maya, the OMToolbox menu has disappeared and need to run through the installer once again to gain access and get it working.
Furthermore, the statusbar, having very little room for all the menu items, dosn't show the OMT item before having clicked the menu bare once.

What the installer does, seems important on this matter as well, so here's a quick resumé:
-Requests absolut path to omtoolbox dir
-Checks for already existing and active userSetup
-Checks for write permissions on the userSetup
-If none: writes a new userSetup to a local directory and sources the old one inside of it.
-Else
-Writes path to the going-to-be-written-to userSetup
---If userSetup is unaccessable: writes a new userSetup to a local directory and sources the old one inside of it.
---If userSetup is writeable: Writes OMT code to the bottom of current userSetup file.
-Writes module file containing the path requested in the first window.
And finally
-When clicking "finish":
---adding the new script path temporary to Mayas scriptpath with "putEnv" (seperation of different pathes is done using the ":" operator)
---executing "rehash"
---starting scriptjob as is done through userSetup
---executing procedure "OMT_toolboxMenu"

As the toolbox works after having run the installer, the manually added script path is ok, which means that the path printed to the module file is ok and the userSetup.mel has been fixed as well, so it makes no sense to me, that it stops working when reopening Maya.

This is what I can make out of the previous posts so far.
__________________
- http://www.jakob.welner.dk - OMToolbox - PAIE -
 
  03 March 2006
Finally got around to reinstalling OMT and now it works as expected, thanks!

/Anders
__________________
dogday-design.se
 
  03 March 2006
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:34 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.