Arnold for rendering particles?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  10 October 2013
Arnold was fast but the results were not what I wanted. I had problems successfully passing opacityPP to the rendered particles - the documentation is not fantastic in regards to rendering Maya particles.

I suppose different renderers have their strengths. Arnold seems to be excellent at rendering high poly count scenes, but its particle toolset is not so well developed. That's fair enough and I respect Arnold for what it can do.

I will use Krakatoa from now on for rendering large amounts of particles. It has great results and very useful tools for what I am trying to do.

A plus point for Arnold: I contacted their support team via twitter regarding their online help page lacking detail. To their credit, they added a new screenshot of the setup on their website for me. That's good support! (The setup they described still didn't work for me, but you can't have everything can you?)
 
  10 October 2013
On the contrary, its really fantastic for rendering particles as well. I'm surprised that the setup didn't work for you. Perhaps you didn't turn off the "Opaque" check box in the particle shape node? Its on by default as an optimization measure. Also, for particles since you will have a lot of overlapping transparent points, you might need to increase the transparency depth setting in Render Settings. There is a Min Pixel Width mode for particles in Arnold as well where you can clamp the minimum size of particles to avoid anti-aliasing issues. Lemme know if you need an example scene setup for testing.
 
  10 October 2013
Thanks Sachin.

A sample scene would be extremely helpful.

The problem I can't get around is that I cannot see any change in the render if I change the opacity of my particles, either per-object or per-particle.

I tried increasing the transparency Depth in the render settings as you suggested but it made no difference that I could see. (This is not mentioned in the Arnold tutorial, by the way)

I am attaching a screenshot of a small test setup showing the opacity settings, render settings, Arnold settings on the particle object and the viewport for the camera. You can see the sort of effect I am going for in the viewport - lots of low-opacity particles overlapping and building a smooth wispy smoke effect. I just cannot get Arnold to obey the opacity properly. Help!







 
  10 October 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:07 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.