C4D Camera not matching in AE

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
  1 Week Ago
C4D Camera not matching in AE

C4D R18, AE 2015.3

I'm having a weird problem getting the C4D camera to link right in AE.

I rendered out the footage, imported it into AE. The rendered footage looks correct.

Brought the c4d file into cineware - the camera does not appear to be the same as in C4D once imported into AE though. As you can see, it does this weird zoom in/out at the end.

Imported the camera from cineware in AE - does not match rendered footage or the camera in C4D.

This has baffled me. Can someone help? Here are some images and video that might describe the problem better. As you can see, in C4D, the camera at the end has a nice smooth curve with flat tangents that bring it to a slow stop. in contract, in AE, this very same camera does some crazy move at the end:

https://imgur.com/a/iKOss orDROPBOX

I had thought I had fixed this problem with making sure the camera import setting was set to "Comp Camera" in cineware - but now it's not working.

Last edited by FalseCathedral : 1 Week Ago at 10:39 PM.
 
  1 Week Ago
The dropbox responds with a 404.
First thing: is it the frame rate the same?
 
  1 Week Ago
Originally Posted by dsp_418: The dropbox responds with a 404.
First thing: is it the frame rate the same?

Framerates are the same across the board, 30fps.

Check the dropbox link, i fixed it. It seems that the actual motion curve of the camera extracted into AE is different than the one in C4D.
 
  1 Week Ago
As you can see here, the curve is completely different in AE than in C4D. This doesn't make any sense to me.


 
  1 Week Ago
Well all, I think I have found the bug.

From this post:
Originally Posted by RyanJP: After many hours and a few tears I realized that if you select a keyframe in C4D there is an checkbox option called "Remove Overshooting" on by default ...this is a great feature but unfortunately CineWare doesn't take it into account!!If you uncheck this you will see the curve that imports into AE, and all will work correctly (after you adjust everything painstakingly). I really hope MAXON fixes this soon.Also in your Document Settings->Key Interpolation you can disable this option being on by default. Hope this helps someone!

So, there was my problem. I think that solves it. The solution was actually to bake the keyframes on my camera, instead of turning off all the remove overshooting options. I also had to do a re-render for some reason. This is so stupid, how the heck did Maxon overlook this?? This cost me a day of troubleshooting.
 
  1 Week Ago
ok that is a bad conversion of curves indeed...maybe send it to Maxon tech support?

Here is a pipeline script that could maybe help:
https://aescripts.com/aec4d/
 
  1 Week Ago
So remove overshooting didn't fix it?

I agree it is bad. What is your C4D version? -edit- disregard , just saw the screenshot.

Last edited by Bullit : 1 Week Ago at 01:15 PM.
 
  1 Week Ago
Have you tried using a .aec? In my experience Cineware is next to useless in the majority of cases.
__________________
Fat Free Media | Twitter
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 02:24 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.