Matchmover points behind the camera

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 09 September 2013   #1
Matchmover points behind the camera

Hi Everyone,

I have recently started using Matchmover, and I am trying to track a forest scene. My problem is that when I solve for the camera, almost half my points end up behind the camera for some reason. The rest of the tracking points are also really close to the camera, and nowhere near the image plane. I have been doing some digital tutors lessons on this, and this issue doesn't come up at all. Would anybody know why this is happening?

My video is a shot looking up into a tree at a branch, where I want to position my own animated creature once in the animation stage. It is hand held with a slight pan, so there is movement and parallaxing.

Any help would be much appreciated.

Thanks,

Lauren
 
Old 09 September 2013   #2
Without seeing the shot and though i know almost nothing
about matchmoving i suspect you do not have a proper solution.
Maybe you can mask out some vegetation especially moving
one( because repetitive patterns can create wrong auto features)
and add prior users tracks (maybe 5-10) manually tracked. Maybe
you would like to exclude green channel (leaves). Start by testing
your solution with a test primitive.
 
Old 09 September 2013   #3
Originally Posted by kyrgr: Without seeing the shot and though i know almost nothing
about matchmoving i suspect you do not have a proper solution.
Maybe you can mask out some vegetation especially moving
one( because repetitive patterns can create wrong auto features)
and add prior users tracks (maybe 5-10) manually tracked. Maybe
you would like to exclude green channel (leaves). Start by testing
your solution with a test primitive.


Hi Kyrgr,

Thanks for the reply. I will try what you said and mask out all the vegetation except for the branch I am specifically trying to track. Hopefully that works. The points behind the camera happen both when I manually track and do an automatic track.

Thanks!
 
Old 09 September 2013   #4
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 04:53 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.