Correct application of texture to 3d cubic structure

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 10 October 2013   #1
Correct application of texture to 3d cubic structure

I have created this cubic structure from a cube by using the extrude tool to pull out each face individually. I want to apply a 1:1 tiled texture to each square face, so each square face has the exact same 1:1 image, and tiled across the structure. Is there an easy way to do this?

I have tried resizing the 1:1 image using cubic projection so it fits perfect on one of the squares, but I cant work out a way to duplicate these settings to drop onto other squares...
Attached Images
File Type: jpg Screen Shot 2013-10-08 at 9.26.57 PM.jpg (11.0 KB, 39 views)
 
Old 10 October 2013   #2
easiest way if its a static mesh is to make a UV texture of the shape and apply the textures that way. You could alps use the clone tool, a mograph selection set and multi shader, but not sure what version of c4d you have?
__________________
mike griggs : creativebloke : 3D, vfx & digital
creativebloke.com
 
Old 10 October 2013   #3
Just to add to what Mike said:

Go into Tools>Modes>UV Polygons
Select All
Right click and select UV Tools>Max UV

That should do it

cheers
__________________
blog
vimeo
 
Old 10 October 2013   #4
I have tried selecting Tools>Modes>UV Polygons

But the 'select all' part im having trouble with..

If I choose Select>Select All it is greyed out...
 
Old 10 October 2013   #5
Originally Posted by digitalmann: I have tried selecting Tools>Modes>UV Polygons

But the 'select all' part im having trouble with..

If I choose Select>Select All it is greyed out...


You need to use the Select All in Select Geometry. Try using the UV Edit layout if you aren't doing so at the moment.

So Chose Tools>Modes>UV Polygons

Then Select Geometry>Select All

Then UV Edit>Max UV

I tried it and it works fine
 
Old 10 October 2013   #6
Tried tools>modes>uv polygons but it seems like nothing is selected. Again select all under select geometry is greyed out.
 
Old 10 October 2013   #7
You've got the object selected plus dragged the UVW tag into the 2D texture view in a BP layout to display the current UV map? Once you do that then change into UV polygon mode the Max UV command should be available.
 
Old 10 October 2013   #8
Originally Posted by digitalmann: I have tried resizing the 1:1 image using cubic projection so it fits perfect on one of the squares, but I cant work out a way to duplicate these settings to drop onto other squares...


I get what the others mean with the UV tools but what you're originally trying should work perfectly fine. If you have set the yellow cubic projection grid to one square, it should keep tiling and repeating onto the other squares, do you have 'tiling' enabled in the projection settings? its just underneath where you set it to cubic.
__________________
Matthew O'Neill
www.3dfluff.com
 
Old 10 October 2013   #9
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:03 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.