CGTalk > Software > Autodesk Maya
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 10-31-2013, 03:41 PM   #1
db23
Veteran
portfolio
Daniel Bullock
Tech Art Direction
Twisted Pixel Games
United States
 
Join Date: Mar 2003
Posts: 67
Send a message via MSN to db23 Send a message via Yahoo to db23
Referencing problem - similar rigs sometimes transfer specific attributes?

Hey guys,

We're using Maya's referencing pretty heavily in our pipeline and for the most part its working great. There are a few quirks but its mostly smooth sailing.

However there is one issue I can't seem to solve consistently.

When importing multiple characters that share a similar skeleton / control rig structure, occasionally certain attributes will get confused and transfer to the wrong bone / controller.

For instance.

- Character A and B are animating together. They share the same basic rig setup and naming, however they're nicely tucked away in groups/layers etc.

- We animate the ears on Character A. Everything looks good. Save the file and close.

- Upon re-opening the file, the animation from Character A's ear has been transferred to Character B. (This sometimes happens with things like the visiblity flag, or other random attributes as well)

This is the problem. A few additional notes.

- There is nothing "special" about the occasional control this happens to that we can see. It is however always consistent within the given file.
- The rigs we use are pretty much global. All names of basic bones and controls are shared. This has not been a probelm 99.9% of the time, and our pipeline pretty much requires it.
- We do not and can not use namespaces, which I realize could potentially help with the problem, so I haven't bothered to test this out.
- Doing the following "fixes" the problem - Open the bad the file, unload the reference to character B, save/close/re-open. Animation is back on Character A's ear.
- If you then reload Character B, save/close/re-open, the problem returns. Always on the exact same controller/bone/attribute.

What I imagine is happening is that somehow the scene is confusing the order of these controllers when it loads, and just applying the data it knows belongs to C_LEar to the first C_LEar it finds, and for whatever reason isn't using the long name to save off the key.

Any one have any thoughts?

Thanks
- Dan
 
Old 10-31-2013, 05:04 PM   #2
Mark-J
Know-it-All
 
Mark-J's Avatar
portfolio
Mark Jackson
CEO & Founder
Red9 Consultancy
United Kingdom
 
Join Date: Feb 2005
Posts: 408
Namespaces are the issue, or rather lack of. The whole of Maya's referencing pipeline really relies on namespaces to partition the data, or rather to virtually partition the data. Are you also running characterSets?

If you look in the edits for any reference you'll see they're just connectAttr(a,b) strings, referencing is basically just one big macro that runs. So without safe namespaces these connects will no doubt get confused.

Why do you say you can't use namespaces?
 
Old 10-31-2013, 05:12 PM   #3
gmask
Obfuscator
 
gmask's Avatar
gmask
Power Sitting
Topanga, USA
 
Join Date: Oct 2002
Posts: 6,937
Yup.. namespaces you must use them or this kind of thing will happen. There is no getting around it unless you want to prefix all your files before referencing them or import your files both of which cause worse problems than dealing with namespaces.
__________________
blah blah blah
 
Old 10-31-2013, 07:20 PM   #4
db23
Veteran
portfolio
Daniel Bullock
Tech Art Direction
Twisted Pixel Games
United States
 
Join Date: Mar 2003
Posts: 67
Send a message via MSN to db23 Send a message via Yahoo to db23
regarding Namespaces - I was afraid of that. I was hoping there was a way I could force the connections to look at the long names for the curves with just a quick startup script or something.

We're not using them at the moment just because our pipeline isn't set up to support them at all, and they do bad things in several areas of our current process.

Theoretically we can support them, we'll just have to spend more time on it than I was hoping. That and retroactively having to figure out what to do with the hundreds of anims we have already.

Thanks for the input.
- D
 
Old 10-31-2013, 09:11 PM   #5
fleabay
Attribute Editor
portfolio
Puddin' Tane
USA
 
Join Date: Jan 2013
Posts: 331
I've seen prefixes mentioned as an alternative to namespaces. I've never used prefixes before, thought it might be worth a mention.
__________________
PlanetVulkan.com
 
Old 10-31-2013, 10:41 PM   #6
gmask
Obfuscator
 
gmask's Avatar
gmask
Power Sitting
Topanga, USA
 
Join Date: Oct 2002
Posts: 6,937
Quote:
Originally Posted by fleabay
I've seen prefixes mentioned as an alternative to namespaces. I've never used prefixes before, thought it might be worth a mention.


Yeah it would mean for every instance of a duplicate rig you want to use that you'd have to create and reference a separate file with the prefix on all the nodes. It's hardly ideal considering there are namespaces that solve that problem. In either case adopting either of these solutions will not fix the current problem of broken animation scenes.

In theory if your animation scenes are ascii you might beable to hack at them to use longnames.. but you might as well just fix all your tools to work with namespaces.

Not using namespaces is so like ten years ago.
__________________
blah blah blah
 
Old 10-31-2013, 10:41 PM   #7
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:36 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.