This render issue is driving me nuts!

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 01 January 2013   #1
This render issue is driving me nuts!

I am pulling my hair out over this. Planar mapped the UVs in the correct axis...its showing up correct in my window and in my UV editor...yet the render is completely off. The render is the perspective view looking straight on from the front.

ARGH. Help!

 
Old 01 January 2013   #2
Go to uv sets on top in the uv editor and see if you have any extra uv sets. Delete any extra's.
Do another uv planar map after and make sure you don't have the checkbox checked to make another uv set. (reset defaults when its open)
Option "c",.. export mesh and re import it, and re apply shader.
 
Old 01 January 2013   #3
Originally Posted by refract: Go to uv sets on top in the uv editor and see if you have any extra uv sets. Delete any extra's.
Do another uv planar map after and make sure you don't have the checkbox checked to make another uv set. (reset defaults when its open)
Option "c",.. export mesh and re import it, and re apply shader.


Thanks for the reply..but no, I don't have any extra UV sets, just the one.

Any other ideas?
 
Old 01 January 2013   #4
looks to me like the UV layout is wrong (perhaps done by automatic layout)... i can see the vien borders touching along the top edge, and the dual pupil on top which tells me the texture is being repeated because the UVs are overlapping.

you can see the overlap if you toggle shaded UV display in the editor... perhaps try cutting the UV in the middle and separating the sides.
__________________
-- LinkedIn Profile --
-- Blog --
-- Portfolio --
 
Old 01 January 2013   #5
Originally Posted by tswalk: looks to me like the UV layout is wrong (perhaps done by automatic layout)... i can see the vien borders touching along the top edge, and the dual pupil on top which tells me the texture is being repeated because the UVs are overlapping.

you can see the overlap if you toggle shaded UV display in the editor... perhaps try cutting the UV in the middle and separating the sides.


It's actually planar mapped in the Z axis. The back of the eyeball even has the same projection due to the planar mapping.

I still can't figure this out.
 
Old 01 January 2013   #6
Maybe you can show the shader network?
Could it be that your texture is using projection mapping?
 
Old 02 February 2013   #7
Heres my shader network.

 
Old 02 February 2013   #8
Chafouin was spot on. You don't want to use neither projection nor 3D. Try delete those nodes including the file node and create a new one. What you want is to UV your eye. Then, while creating the file node, check on the left of your hypershade to make sure you choose 2D and not projection.
 
Old 02 February 2013   #9
Originally Posted by Panupat: Chafouin was spot on. You don't want to use neither projection nor 3D. Try delete those nodes including the file node and create a new one. What you want is to UV your eye. Then, while creating the file node, check on the left of your hypershade to make sure you choose 2D and not projection.


Hmm, this is what's odd and I know something is not right.

Here's my steps that leads to the above shader network I posted.

- Create Mia_material_X
- Assign it to my sphere
- Select sphere, then Create UVs > Planar Mapping in the Z axis
- Assign a 2D file to the Diffuse of the Mia_X

Doing all of that results in the above shader network. I even tried creating a new scene, and MAKING SURE I selected 2D File from the left column of the Hypershade. There is no 2D node created at all, only what you see in my shader network post.

Is something corrupted?
 
Old 02 February 2013   #10
when you get to the part where you click on "file" in the hypershade selection thingy dont click on it. RIGHT CLICK it and do "create texture"
__________________
 
Old 02 February 2013   #11
In the hypershade, in Create > 2d textures, make sur that the radial button at the bottom of the list is 2d normal, and not 2d projection. Then it will save the setting and always create your 2d textures without the projection node in your network, and it will use your UVs.

And when you occasionnally want to create projected texture, you can right-click on File on the left panel, and choose Create as projection, as Cyberone said.
 
Old 02 February 2013   #12
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:07 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.