Xpresso stopped evaluating in R14... Why?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  02 February 2013
Xpresso stopped evaluating in R14... Why?

Hi;

I have a single null object to which I assigned an xpresso tag that bears all my expressions for a rig in a scene. Everything was working fine, until I reopened the scene and found to my surprise that everything stopped evaluating. As of now, nothing works... I checked and double checked the ref names on every graph, each and every node, and the evaluation check boxes in the layer manager; everything is in order, yet nothing is evaluating... I even checked the project settings, expressions are enabled. Like I said, I just saved the scene and reopened.

How could this possibly happen?

Any help would be wildly appreciated.

Thanx

AJ
__________________
consumpta est...

Last edited by Jacobo : 02 February 2013 at 01:38 AM.
 
  02 February 2013
you might have accidently disabled one of your xpresso groups/ the xpresso tag.
 
  02 February 2013
Yesterday I found that one Expresso node lost it's connection to a deleted object (when the ports of the node show undefined). This stopped the entire expresso setup. Before, the rest would continue working but nowadays it seems to stop everything.
 
  02 February 2013
Yes, but like I said, I checked and rechecked and there wasn't a single unreferenced object node in the graph... It's absolutely nuts... :(
__________________
consumpta est...
 
  02 February 2013
Hi,
not only look for undefined nodes but also for undefined ports. I had a setup that stopped working from R11.5 and R12 because in R12 some display attributes were changed and I was controlling them via xpresso. Other than that you may try the new Performance View in R14 to see wich nodes are being calculated.
__________________
www.visualtricks.it - www.c4dzone.com
 
  02 February 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:54 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.