Use_background: renderview ok..renders not

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Display Modes
  02 February 2018
Use_background: renderview ok..renders not

I have a scene with use_background applied to a plane (as terrain) so I can catch a shadow from an object moving through the scene. When I use Render View to check things, it looks okay and the shadow appears, etc. --But when I then Batch Render the scene, the use_background plane is black...not transparent as expected. Alpha channel is selected in the Render Settings, and I can tell the shadow is there, but for some reason when actually rendering the frames it isn't transparent--just a black blob. Why it works in Render View but fails in the actual render images...don't know.

If it matters, I've come back to this scene from a year ago, and back then I'd been testing rendering with Arnold and Redshift. The terrain plane is named "ShadowCatcher_terrainshape" which leads me to think I'd originally applied an Arnold material to it. But because I don't want to have to change other Mental Ray materials in the original scene, I've switched back to rendering with Mental Ray and so I've applied the "use_background" material to this plane now. Could that have something to do with the problem...maybe some Arnold attribute is locked in??
As I said above, it works in the Render View image, but not in the final renders, and both are rendering using Mental Ray now.

Anyone have a clue on this...I'd appreciate the help.
JTT
 
  02 February 2018
To follow-up, I've attached an image to illustrate the problem. The left image is what it should look like, this sample is taken from the 'Render View' window and shows the small shadow that's caught on the plane with use_background applied. It also renders fine if I enable rendering with 'mentalRay' in the the view panel. But if I try to actually render the image...the plane goes black as shown on the right. I've read online that some people have had issues with Final Gather in the render settings, so I'm checking on that...and at the moment I do feel it's something in Render Settings, but if anyone has other ideas, I'd appreciate the info. Thanks.
 
  02 February 2018
this line is confusing...It also renders fine if I enable rendering with 'mentalRay' in the the view panel.

Why are you using a Maya node instead of MR mip_matteshadow or a rayswitch?
 
  02 February 2018
Well, since you have a point and I really don't have a good answer why I was using 'use_background', I switched to 'mip_matteshadow'...

So, I've made some progress and can now get the shadows to appear and the shadow catching plane to be transparent instead of black... hallelujah! That said, I'm getting a strange result in that the plane with mip_matteshadow applied has the background image much brighter than should be. See the attached image.

I've played with some of the available settings hoping to find the one that's causing this, but so far no luck. Both images, the one used on the image plane in the background as well as the one mapped to the mip_cameramap node, are the same images in the same image sequence, so why one appears brighter than the other is a mystery to me.

Any thoughts, anyone? Thanks..

 
  02 February 2018
I'm suggesting you to find a mip_matte_shadow workflow and don't use the imageplane for render final image but mip_camera_map and the relative correct color space(gamma)

https://www.youtube.com/watch?v=DF078Nnt8Rw
__________________
www.darioortisi.it
MayAdvanced Blog
My youtube channel
 
  02 February 2018
I'm a bit confused by what you wrote, so forgive me if I need some clarification. Fwiw, I've used mip_matteshadow at times in the past with good results, and I've actually seen that youtube video before as well, and the Zap's tips he referred to. Even so, I started over and recreated all the nodes step by step as shown in the Youtube video, and inserted another simple plain, just to see if I might have missed something. Unfortunately, I still get the same result. Whatever geometry has the mip_matteshadow applied still shows up brighter than the image plane background.

Looking closely, it's almost as if there is a translucent quality to the lighter area, like looking through very thin milky glass, and the foreground areas are still fairly clear and distinct, but the farther back the plane goes the more fuzzy the image seems to get. I've checked lighting, and reflectivity every where I can think of (in case that was it), but so far testing and retesting...no change.

That said, I don't understand what you meant by "don't use the imageplane for rendering the final image"? My understanding (and it was this way in the video) is that you have to have an image plane to provide the background to match what is being mapped to the matteshadow geometry (the plane in my case.) So how can I not use the image plane for the final render?

Thanks for the help..
 
  02 February 2018
please look at this. On the first you can see the alpha 0 for the image plane. I'm usually fix it to -1(negative 1)

https://www.youtube.com/watch?v=yGjkGw2F8gE
__________________
www.darioortisi.it
MayAdvanced Blog
My youtube channel
 
  02 February 2018
Hey there, I have checked everywhere for a fix to this problem, I got this problem in my scene a few days ago when using the "Use Background Shader" with mental ray on a cube to catch shadows and reflections on a live plate. However, I think I have found a fix. It may be a memory issue or a lighting and expression issue, not really sure. In the render settings under the common tab, go to scene assembly, and switch from active representation to custom, then I checked the box saying "Use Regular Expressions" and I also Enabled the default light and made it cast nothing. if possible make the Ratio "device aspect" instead of "pixel aspect". I checked "Maintain width/height ratio aswell. Also turn on the "Renumber Frames Options, leave them both at 1.000. After trying a few things I found that you also need to have a data type of "RGBA (Float) 4x32 Bit" under the Scene tab (Primary Framebuffer) and you cant have the motion blur option turned on, it must be "OFF". I tried both Open EXR and TARGA and they both seem to work fine, haven't tried the others. Once you have those render settings, you need to create a new layer in the Channel box/Layer Editor on the right and move all your obejects and camera to that new layer, then turn OFF the rendering of the master layer and ON the rendering of "Layer 1" the final step is when batch rendering, open the settings box and turn off the "Auto Render Threads" change to (8) and turn off the "Auto Tiling" change to (64) and turn off the "Auto Memory Limit" I set mine to (4000) and I had a problem, then I tried (2000) and it worked just fine, last thing is you need to turn OFF the box "Render on Network machines" it renders a little slower than maximum power, but who knows if thats the issue :/ im pretty lost at this point, I have been changing settings for about 14 hours now, and this is the only thing that has worked for me, hope this works for you! As for what Maya is telling me through the logs its pretty much nothing, however, I noticed a flicker on every render that crashedso I assumed it was the program faulting for a second and the code jumping to the end of its sequence so changing the settings leaves Maya in a state of permanently rechecking its processes and not skipping becauseof the blank expressions. But really I just need sleep, -__- also I did not want to use theMip_MatteShadow so I tried this. Rip me. As for your brightness issue, I haven'ttried any fixes but see if you can find a "premult"option somewhere in the node itself :/ other than that, no clue. let me know if the settings work, hope it does! Pce.
 
  02 February 2018
Thank you..thank you..for getting me to realize your point about using the camera's 'environment' vs the imagePlane. For whatever reason it suddenly came to me and I understood what you were saying. Definitely after this last link you sent I wonder why it just didn't occur to me earlier. So, that definitely resolved the odd lighting problem and I'm finally getting things to work the way they should.

Fwiw, I'd simply switched off visibility on the imagePlane, though you (and he) pushed the Alpha down to 0 or -1. Is there some advantage to adjusting the Alpha over turning off visibility?

Thanks again...have a great week!
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:42 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.