3DS Max viewport issue

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  08 August 2013
3DS Max viewport issue

Hi

I am running 3ds max 2012, on windows 8 64bit. I have a Nvidia GTX 285 with version 314.07 drivers. I have tried multiple versions of drivers and I experience the same issues every time.
I also have 12 gigs of ddr3 1600 ram and on an I7 cpu, if thats of any use to know.

I am running in direct 3d 9.0

The issue I have is, when I am panning/rotating around my scene, I start to get strange glitches and tearings in my geometry. This seems to get progressively worse the longer I am in the scene and the heavier it gets.
It appears to be happening worse, where there is geometry behind another piece of geometry (however not touching it). I tend to see the geometry behind flicker over the top of the geometry that is in front. Its an aweful mess.
I work with my units set to MM, and I work with real-world values.

I am thinking of upgrading my graphics card anyway, however I dont want to spend money to have the same issues re-occur.
I have had my GTX 285 for a very long time now, could It be a sign of its death? I really dont know what is going on. I have been experiencing this for a while, however it was never like this in the beginning. I have started to get quite fed up and want the problem fixed.

Any suggestions would help so much,
Also what would a worthy upgrade be? A high memory card like the titan would be nice for vray RT, but I dont use RT enough to justify a large spend.
My main concern is for viewport usage, plus I dont use my PC for gaming really.

Many thanks,
Daniel.

Last edited by purostar : 08 August 2013 at 12:48 AM.
 
  08 August 2013
Does the problem go away if you zoom in? Could be just viewport clipping.
__________________
The Z-Axis
 
  08 August 2013
Originally Posted by darthviper107: Does the problem go away if you zoom in? Could be just viewport clipping.


Thanks for the reply.

I wouldn't say it goes away, however the garbled mess does clean itself up when I zoom into an area of geometry.
That said toggling 'Viewport Clipping' on and off in the viewport menu doesnt seem to help at all, the issue still happens when viewport clipping is both on and off.
 
  08 August 2013
Heres a quick screen grab, the problem usually gets alot worse than this.
The areas that show the most garbled mess, usualy is where a surface is fairly close to another surface, causing this black type of clashing of triangles.
If I zoom into an area that shows the black mess, the problem goes away, however when I zoom back out, it comes back again.

 
  08 August 2013
Yeah, that's just viewport clipping. When you turn on the viewport clipping option, there's a yellow slider that shows up on the right side of the screen, adjust the level on the bottom and that will change the tolerance. Usually it changes how close a view can get to an object before it gets clipped, but it also adjusts how close surfaces can get before they show Z-fighting. The z-fighting effect can happen when you zoom out because in the viewport the precision starts degrading the further away something is.
__________________
The Z-Axis
 
  08 August 2013
That's Z-Fighting. It's the back faces showing through the front because of a lack of precision in the Z-buffer values. Usually this happens if the object is really far from the origin or very tiny.

if you can move the whole scene nearer the origin it should get better. And check the system units (not display units) are ok if you are using mm, check the object is a reaonsable scale for that. (1 unit being the smallest usable scale is a good rule of thumb). normally cms is fine for something at human scale.

If you've enabled viewport clipping, did you pull the top slider UP, and the bottom one (near) down? If so, don't. Pull the top one down as far as possible and the bottom one down only if you need to, to not clip the object. The range of Z values is stretched out between those two markers so the further apart they are, the lower the precision you have. They need to be as close together as possible.

But normally if you're working in a reasonable scale and not far from the origin you don't need to enable manual viewport clipping at all. Max works it out itself from the bounds of the scene.
 
  08 August 2013
D3D?
Why dont switch ti NITROUS?
__________________
http://trideval.blogspot.com/
 
  08 August 2013
Thanks for the replys, i really appreciate the advice.

I double checked my scene, and I am working from the origin, I do tend to make sure when I start out that I model from the origin. My system units are set to MM and my display units MM aswell. I did try setting the system to CM, but it didnt make a difference in terms of the Z fighting.
When I model, I work to real world values, I mainly do architectural stuff, so I try and model things as accurately as I can.
I still havnt managed to fix this :(

So the problem definetly seems to be Z-fighting? Not my graphics card? I assume I would get the same Z-fighting issues on all graphics cards?
 
  08 August 2013
Yeah, you'd get the same issues on any graphics card.

If you want to avoid it, you can adjust the viewport clipping slider, or I think if you reduce the dimensions of the scene then it will help---meaning that if you have your main stuff at the origin, but you have another object that's really far away from there it can cause the Z-fighting to appear because the precision would be based on the size of all the elements in the scene.
__________________
The Z-Axis
 
  08 August 2013
Thanks for the reply, you have helped me immensely by narrowing down the issue here.

So should I re-think how I set up my system units?

Should I be using MM for real world sizes? The way I have set it in the past, is 1 unit = 1.0mm

This would mean things that havnt got much of a thickness, such as glass, would end up around 15.0mm and like other small details that like are going to Z fight I am assuming.

Should I be setting my units up in another way? Maybe have some like 1 unit - 10.0mm and then add on a '0' to every measurement? I dunno, maybe thats a stupid idea. I am feeling rather clueless right now.
 
  08 August 2013
For something like that, I wouldn't actually use millimeters, and if you are using millimeters make sure your system units are actually set to that--they don't have to display millimeters (you can still use generic units) but by default 1.0 = 1 inch
For me, if I'm doing like interiors and a single building, I use inches, if it gets bigger I use feet. If it's very small, like something I can fit on my desk then I use millimeters.
__________________
The Z-Axis
 
  08 August 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:54 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.