Team render works great on single frame, then becomes slow when rendering a sequence

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Display Modes
  01 January 2018
Team render works great on single frame, then becomes slow when rendering a sequence

1 machine takes 60 seconds to render a frame. with TR that same frame takes about 40 seconds. However, when I send the entire sequence to render each frame is taking almost 2 min!

I'm back to just using a single machine for now and settling for 60sec/frame but I'm really curious as to what would cause this. Why would TR work for a single frame not with more than 1 frame? The animation itself does not change. Its just a slow pan above a city.

Any thoughts?
__________________
PTACNIK.COM
 
  01 January 2018
What can you tell us about the scene? What renderer are you using? Is there GI? Mograph simulations or caches?

What can you tell us about your primary workstation and the render nodes? Are you using a high speed network? You could have a bottleneck there.

Are your nodes retrieving geometry/textures from the server every frame, or do they take extra time at the beginning to get all the assets first?
 
  01 January 2018
Originally Posted by LukeLetellier: What can you tell us about the scene? What renderer are you using? Is there GI? Mograph simulations or caches?

What can you tell us about your primary workstation and the render nodes? Are you using a high speed network? You could have a bottleneck there.

Are your nodes retrieving geometry/textures from the server every frame, or do they take extra time at the beginning to get all the assets first?

Low poly buildings in a mograph cloner. A physical sky creating fog with additional fog created via a volumetric light (only light in the scene) The building are a very simple black texture and its basically silhouetted buildings in a foggy environment. No Gi. Standard renderer. Only the beauty and a depth pass.

Main machine: i7-4790k using 7 threads. 32gb ram. 1080ti 11gb
Second machine: i5-7500 using all 4 threads. 8gb ram.Quadro FX 3800 1gb
1gbe network connection

Each machine works fine by itself. And work great together when its just a single frame. Only having problems when combined+seq.

"Are your nodes retrieving geometry/textures from the server every frame, or do they take extra time at the beginning to get all the assets first?"

I hadn't thought of this. I'm new to TR so not sure I have this set up correctly.
__________________
PTACNIK.COM

Last edited by ptacnik : 01 January 2018 at 09:26 PM.
 
  01 January 2018
Here are my Team Render settings that have worked quite well for me:



Sometimes it takes a few minutes for TR to 'get going' - making the first frames that each workstation render longer than the rest (the same thing will occur if one workstation finishes a section of frames and begins work on a new section - the first frame of the new section will take longer than the rest).
 
  01 January 2018
may it be, that one frame is rendered on the4790k?
TR uses DR for one frame so both mashines render the frame together in 40sec.
rendering serquences single frames are always rendered on one client each. so maybe the 2 min frames are the ones rendered on thei5-7500 ?

That would mean, that the4790k is not rendering the sequence. maybe it is busy with preparing a later frame to start rendering (if you have huge preperation times and may frames)
or you have some frames in the animation that need much longer to render in the second half of the animation?
you could check which frames are rendered on which machine.

best regards
Jops
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:15 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.