MPxGeometryOverride with a simple triangle in viewport 2.0

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Display Modes
  07 July 2018
MPxGeometryOverride with a simple triangle in viewport 2.0

Hi everyone,
I wrote a simple class derived from MPxGeometryOverride and applied it to a triangle, only to see it disappear. updateDG(), updateRenderItems(), populate geometry() are all being called. Maya creates 6 default render items,; 2 StandardShadedItems, 2 FlatShadedItems, 2 OSDAdaptiveShadedItems. I have registered it with string drawdb/geometry/mesh. My scene contains a single triangle. As soon as I load the plugin, it disappears. Not even the outline is drawn. The geometry requirements given to me asks for two vertex buffers viz position, normal and surprisingly asks for zero index buffers. Now, I know that I haven't given an awful lot of information but what could possibly go wrong for a triangle? Any ideas as to how I can proceed with debugging?
 
  07 July 2018
Alright. I solved the issue. Thought the index buffer requirements are zero, you need to create an index buffer and associate it with each render item.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:45 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.