CGTalk > Software > Autodesk Maya > Maya Rendering
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 02-08-2013, 07:20 AM   #1
n3al
Veteran
 
n3al's Avatar
portfolio
Neal Albert Strydom
Digital Designer & Social Media Administrator
College SA
Kraaifontein, South Africa
 
Join Date: May 2012
Posts: 50
Maya Discarding Material assignments

Hi there, I have a big problem with my Maya, whenever I save m scene and exit Maya, then start Maya up again and want to start working, I find that Maya has discarded the assigned shaders to the geometry. All geometry in the scene is referenced in from the main folder, and I find that I can't select groups and assign any materials to selection, I get the error, 'error wile parsing arguments'

I'm using Maya 2013 and Mental Ray. I find that Maya does it only to my AO shader and masking shader. For the AO, I have a surface shader, with an amb mib texture node plugged in to the out color and for my masking shader, I have an 'use background' shader with everything turned down except shadow mask on 1.

Any ideas or suggestions?

Thanks
Neal
 
Old 02-11-2013, 05:59 AM   #2
snikt
Frequenter
 
snikt's Avatar
portfolio
Rahul Dasgupta
Mumbai, India
 
Join Date: May 2004
Posts: 127
ditch the surface shader

If the surface shader comes as a layer override in any layer, there are very high chances of this break happening
 
Old 02-11-2013, 01:49 PM   #3
lostparanoia
Care bear
Mikael
VFX artist - 3D
Malmö, Sweden
 
Join Date: Dec 2005
Posts: 636
Did you assign any shaders to specific faces instead of entire objects? or maybe you performed a boolean, extract, separate or combine operation which will automatically assign shaders per face? This will often break your render layer shader assignment. It's an old, terrible bug in maya.

Delete all render layers, make sure all shaders are assigned per object, and then redo your render layers.
__________________
"No, the movement is good, it just has to travel faster from spot A to spot B in the same amount of time."
 
Old 02-11-2013, 02:24 PM   #4
thehive
Expert
portfolio
Eric Robert
animator/ illustrator
work/\holic Studios.com
Orlando, United States
 
Join Date: Feb 2005
Posts: 1,687
ive have had this issue a lot how do i properly prep layers so they doent break or is that how maya is. can be a paint to fix on a dead line
 
Old 02-12-2013, 07:13 AM   #5
n3al
Veteran
 
n3al's Avatar
portfolio
Neal Albert Strydom
Digital Designer & Social Media Administrator
College SA
Kraaifontein, South Africa
 
Join Date: May 2012
Posts: 50
I have the shader assigned to the geometry objects, I haven't assigned any layer overrides or any per face assigning. I also have no idea on how to do a boolean extract. I read up on the error and found that this happens due to name clashes when using the render layer system and passes, so I've fixed all that, but my problem now, is that the misss fast x shader passes node, won't render in the render passes, except in the master beauty pass, I'm using diffuse material color, direct irradiance no shadow and raw shadow for my passes and then the AO pass. I went into another instance of Maya and tried again, and found the same result. What shader should I use for skin then, if the one that works ideal for skin, won't render in the passes?
 
Old 02-12-2013, 08:12 AM   #6
n3al
Veteran
 
n3al's Avatar
portfolio
Neal Albert Strydom
Digital Designer & Social Media Administrator
College SA
Kraaifontein, South Africa
 
Join Date: May 2012
Posts: 50
Ok, so I tried creating a setup for a RGB pass, so that I can just use it in compositing stages, but I'm still running into the wireframe issue and the discarding of shaders, what I've also found, is that when I select the object in my outliner, I get the error, 'error while parsing arguments' for assigning a shader to an object, but when I select the object in my viewport and assign it, then the assigning works, until I exit and restart Maya....
 
Old 02-12-2013, 08:12 AM   #7
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 02:22 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.