Turbulent flames with xpDomain

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
  2 Weeks Ago
Turbulent flames with xpDomain

Does someone know if the turbulence modifier is supposed to work with xpDomain?
I am trying to create flames from a sweeped spline. The problem is its all very even and I want to see more flames of different sizes and turbulence.
Somehow I don't see any effect of the turbulence modifier.

I tried to post on the xParticle forum but while uploading it gives me "this site is not available"



__________________
C4D R19 Studio, V-Ray, 3D-coat, MarvelousDesigner, Substance Painter/Designer, Houdini Indie, Rhino
Website
 
  2 Weeks Ago
Robert,

The turbulence is working fine here, not sure the setup is the same though:


 
  2 Weeks Ago
Thanks a lot Marco :-)

Ok, you have a separate emitter while I was thinking that I could do it with the domains internal particles.
And indeed with a linked emitter the turbulence modifier works fine.
However two problems...
1- The domain fills itself with its internal particle and ads the particles from the linked emitter to it.
2- I can not have the flames show up from the domain's display.

Must be something I am missing I guess but what?
Also I searched on the net but until now did not find one example of how to create flames from particles.

Regards, Robert




__________________
C4D R19 Studio, V-Ray, 3D-coat, MarvelousDesigner, Substance Painter/Designer, Houdini Indie, Rhino
Website
 
  1 Week Ago
Robert,

Looking at the image in your first post, and reading about your need for a turbulence, here's what I think you're trying to achieve:
- Have the particles emitting from a rectangular shape
- Have the particles being affected by turbulence
- Keep the particles in place, so they don't move up or fill the domain

Hope that I've got it right.
If that's the case, I would create the emitter and the domain, also I would create a rectangular spline.
I thinkMario Tran Phuc explained at the IBC that emitting from an object rather than the default x-particles emitter should give you a better result with more details.
I would change the particle direction to Y+.
Then, I would play with the domain settings, so maybe you need gaseous and reduce the particle speed.
If that's not enough, you can always add a Gravity modifier, or speed or a combination of both.

Let me know if that helps.
Good luck!
 
  1 Week Ago
Here's a site that seems to get into all the aspects you mention.

https://vimeo.com/zeroabsolu
__________________
David

iMac 3.06 ghz Intel Core 2 Duo / 16 GB / OS 10.13.4 / C4D StudioR12 / CS6
 
  1 Week Ago
Thanks Marco..

Yes you are right, that's exactly what I want :-)
And that's how I setup my scene also, with those results.
As an experiment I created a polygonal object to emit the particles from and that solved the not showing up in the display.
The other problems still exist. Maybe I should try an earlier version of xParticles, the whole thing gives me unreliable results each time.

Regards, Robert
__________________
C4D R19 Studio, V-Ray, 3D-coat, MarvelousDesigner, Substance Painter/Designer, Houdini Indie, Rhino
Website
 
  1 Week Ago
That a great link David, thanks a lot.
I don't understand French but can somehow follow along.
I start to wonder if it makes more sense to do this with pyrocluster, this is taking an absurd amount of time.

Regards, Robert
__________________
C4D R19 Studio, V-Ray, 3D-coat, MarvelousDesigner, Substance Painter/Designer, Houdini Indie, Rhino
Website
 
  1 Week Ago
Thanks to the video's David suggested i managed to solve the main problems.
Rather than linking the emitter to the domain; I kept it separate and added a gaseous modifier.
I now have much more control over what's happening and also got rid of the internal particles from the domain.
Still trying to figure out the voxels size, because when I go for a higher resolution I lose the main shape of the flames, everything becomes leveled out rather than the other way around.

Anyway, thanks gentlemen for your help....
Robert
__________________
C4D R19 Studio, V-Ray, 3D-coat, MarvelousDesigner, Substance Painter/Designer, Houdini Indie, Rhino
Website
 
  1 Week Ago
Robert, I check your PM, hopefully, that can help.
 
  1 Week Ago
Originally Posted by dsp_418: Robert, I check your PM, hopefully, that can help

Thanks Marco that's very kind of you :-)
I checked your file and it's basically the same set up that I used, only at first I had linked the emitter to the domain by using 'particles (gas)'.
This resulted in the extra internal particles. Still not sure of the use of this mode. Anyway I now added a gaseous modifier to have more control over the particles.
The real challenge is when you want to turn the particles into flames (in your file you did not), and if you managed to do that, render them as you see in the preview.
Till now I came a little closer to what I need but for the moment I decided to do something quick and use pyrocluster driven by TParticles.
It's not as satisfactory as I would like, but for the moment, it will do.

Thanks again for helping, Robert
__________________
C4D R19 Studio, V-Ray, 3D-coat, MarvelousDesigner, Substance Painter/Designer, Houdini Indie, Rhino
Website
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:47 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.