optimizing workflow with dense scenes

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Display Modes
  11 November 2009
optimizing workflow with dense scenes

Is there a way in which I can speed up my workflow in max when im using dense particle scenes (aside from turning the event off)? Im trying to make a grass and corn field in a scene and its getting dense to the point where I can't even shut the event off because max is lagging so hard. Any help is appreciated, thanks everyone!
 
  11 November 2009
Lower your viewport particle count. This can be done per event in the Display Op as well as in the Global PF Source node.

Cache events.

Turn off Display Geometry and use Dots, Ticks, Circles, ect. instead.

Try switching between OpenGL and D3D and see which performs better for you.

If you are using animated shape instances as your particle shapes, turn off animated shapes until you are ready to render. Or use a non animated proxy object until you are ready to render.

Turn of realtime in the Time Config

Update Forward instead of Complete in the Particle View->Options Menu

Disable all of your viewports so only the active one is updated.

Couple things to try anyway
__________________
poof ~>Vimeo<~

Last edited by JohnnyRandom : 11 November 2009 at 04:23 PM.
 
  11 November 2009
cool suggestions! im currently just displaying all of the particles as ticks in the scene, with different colors to see how it will lay out at least.

How do the cache events work? I tried adding them before but didnt seem to do much, but thats probably because I was using them incorrectly.

Thanks for the help!
 
  11 November 2009
Just add a Cache Operator to each event you would like to cache and choose the appropriate settings, such as caching viewport or cache viewport and render, integration step sampling, ect.

You can adjust the amount of ram assigned to each operator and the bottom of the parameters rollout, the default is 100mb. Obviously if you are cache a lot of events it would be advantageous to be running 64-bit version of max to utilize greater amounts of physical memory allowing you to cache even greater amounts of particles.

Of course if you have box#3 you can use the cache to disk operator to remove the limits of physical memory that you have installed, albeit it is slower since you are reading from disk.
__________________
poof ~>Vimeo<~
 
  11 November 2009
sweet! thank you!
 
  12 December 2009
Originally Posted by JohnnyRandom:
Update Forward instead of Complete in the Particle View->Options Menu



nice tip
__________________
you already missing my blog cgroute.com
 
  12 December 2009
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:37 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.