CGTalk > Software > Autodesk Maya
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 04-04-2013, 02:23 PM   #1
hellspawned
Know-it-All
Tomas Landberg
Huddinge, Sweden
 
Join Date: Sep 2004
Posts: 430
Wavy, distorted normals

Hi!

I'm have a problem, a rather major one: When trying to bake normal maps off of circular objects, the normals come out wavy, as this article describes: http://www.chrisalbeluhn.com/Normal_Map_Tutorial.html
The relevant part is about halfway through the article.

Either way, I've tried to do what he says, editing my cage mesh so that, I hoped, the projection around the side would be horizontal. But it doesn't. It seems like the cage is largely ineffectual in Maya. So, does anyone have any idea of how to sort this out?
 
Old 04-04-2013, 07:39 PM   #2
Daemonecles
Wearer of Ninja Pants
 
Daemonecles's Avatar
portfolio
Andres Weber
CG Generalist
MPC
New York, USA
 
Join Date: Jul 2007
Posts: 346
Send a message via AIM to Daemonecles
The cage in maya actually doesn't do what is expected. When you try to do per vertex changes to the mesh they won't work as intended. Usually you can make a cage mesh on your own in maya and then do the bake in something like xNormal so that you can make use of the cage function. Or work with your UVs to remove the issue.
__________________
MPC NYC
Andres Weber | CG Generalist
434 Broadway, 9th Floor, New York City, 10013
GChat AndresMWeber
www.moving-picture.com
 
Old 04-08-2013, 07:06 AM   #3
hellspawned
Know-it-All
Tomas Landberg
Huddinge, Sweden
 
Join Date: Sep 2004
Posts: 430
How do I include a custom cage mesh in xNormal? Not overly familiar with that application, apart from the most basic baking tools.
 
Old 04-08-2013, 07:57 AM   #4
hellspawned
Know-it-All
Tomas Landberg
Huddinge, Sweden
 
Join Date: Sep 2004
Posts: 430
Nvm, I found how to include my custom cage.
Now, for the next problem: My imported lowpoly meshes normals doesn't seem to import (or be interpreted) correctly. My object is an 8-sided hamburger for a mobile game prop. When baking the map, I get very sharp lines going vertically in the normal map, even though all my normals are smoothed on the object I exported. Has it got something to do with using .obj to export the mesh? I've experienced .obj files being imported fully faceted before, even though they weren't faceted in the application I exported them out of.
 
Old 04-08-2013, 12:59 PM   #5
Daemonecles
Wearer of Ninja Pants
 
Daemonecles's Avatar
portfolio
Andres Weber
CG Generalist
MPC
New York, USA
 
Join Date: Jul 2007
Posts: 346
Send a message via AIM to Daemonecles
I would need to see a picture of the issue to do some triage.
__________________
MPC NYC
Andres Weber | CG Generalist
434 Broadway, 9th Floor, New York City, 10013
GChat AndresMWeber
www.moving-picture.com
 
Old 04-08-2013, 12:59 PM   #6
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:24 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.