CGTalk > Software > Pixologic ZBrush
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 01-17-2012, 12:40 PM   #1
ezekiel66
Know-it-All
 
ezekiel66's Avatar
portfolio
v j
3D Artist
Germany
 
Join Date: Oct 2004
Posts: 422
Disable rightclick menu?

I would like to have the right-click navigation enabled (Preferences -> Interface -> RightClick Navigation), but I do not want any menu to appear when I click the model with the right mouse button.

Very often when I right-click to rotate in the viewport the right-click menu appears, and very often I accidently click the menu with the ALT button pressed so it is docked over to the right side of the UI which is very, very annoying.

Is there a way to deactivate the right-click menu in ZBrush?
 
Old 01-17-2012, 03:46 PM   #2
hsanden
Veteran
portfolio
Henning Sanden
MPC
London, Denmark
 
Join Date: Mar 2006
Posts: 94
Send a message via MSN to hsanden
As far as I know, it's not possible, at least in a straight forward way.
 
Old 04-15-2012, 02:05 AM   #3
ArtPotato
Frequenter
 
ArtPotato's Avatar
portfolio
Michael McDonald
Mid-Level Artist
EA
Melbourne, Australia
 
Join Date: Mar 2006
Posts: 156
I would really love to have the right click menu disabled as well. its driving me crazy!

Why?... well because I come from a Maya and Max background that's why (just like 90% of the entire industry)

I use Right click to navigate around the viewport. And if my camera pan movement is too small, or if I right click but dont clcik ctrl or alt or whatever fast enouf. it brings up the right click menu instead, generally causing me to scale my brush up/down rather then panning around my model.

space bar brings the menu up anyway. would be fantastic to remove it from the right click function all together.

And if anyones gonna post some typical "Learn how to use ZBrush better" then dont bother caz I know there are 100's of others wanting in my position based on all the forum posts out there.
__________________


 
Old 04-15-2012, 02:22 AM   #4
informerman
Expert
 
informerman's Avatar
portfolio
EZ-Brush
dallas, USA
 
Join Date: Dec 2011
Posts: 879
(Preferences -> Interface ->click time 0.01
 
Old 04-15-2012, 11:00 PM   #5
ArtPotato
Frequenter
 
ArtPotato's Avatar
portfolio
Michael McDonald
Mid-Level Artist
EA
Melbourne, Australia
 
Join Date: Mar 2006
Posts: 156
OMG!!! You are my hero!

Hahaha been putting up with that for months
__________________


 
Old 04-16-2012, 09:16 AM   #6
ezekiel66
Know-it-All
 
ezekiel66's Avatar
portfolio
v j
3D Artist
Germany
 
Join Date: Oct 2004
Posts: 422
Nice. Thanks for the hint.
 
Old 05-15-2012, 12:42 AM   #7
informerman
Expert
 
informerman's Avatar
portfolio
EZ-Brush
dallas, USA
 
Join Date: Dec 2011
Posts: 879
some one said the click time may effect things like selecting polygroups.

this way you can turn it on or off.
once loaded look in ZPlugin>Misc Utilities
Code:
[ISubPalette, "ZPlugin:Misc Utilities",0] [IButton, "ZPlugin:Misc Utilities:Right click ON", "Right click ON", [ISet,Preferences:Interface:Click Time,0.25]] [IButton, "ZPlugin:Misc Utilities:Right click OFF", "Right click OFF", [ISet,Preferences:Interface:Click Time,0.01]]

the bottom of the code that says [ISet,Preferences:Interface:Click Time,0.01]
you all so may try changing it to 0.1
[ISet,Preferences:Interface:Click Time,0.1]

like this
Code:
[ISubPalette, "ZPlugin:Misc Utilities",0] [IButton, "ZPlugin:Misc Utilities:Right click ON", "Right click ON", [ISet,Preferences:Interface:Click Time,0.25]] [IButton, "ZPlugin:Misc Utilities:Right click OFF", "Right click OFF", [ISet,Preferences:Interface:Click Time,0.1]]


this will allow the right click mouse off but you can all so select polygroups with out it messing it up
AS Long and you click fast, click and release the left mouse button fast, do not hold.

if i was you i would use the second code.
works the best but dont right click and release the left mouse button fast

Last edited by informerman : 05-15-2012 at 01:03 AM.
 
Old 05-15-2012, 01:34 AM   #8
informerman
Expert
 
informerman's Avatar
portfolio
EZ-Brush
dallas, USA
 
Join Date: Dec 2011
Posts: 879
here is a little tip encase you dont want to use a zscript to click it to turn it on or off.
or having any other problems like selecting polgroups.

most peoples left clicks are faster then there right click.
slide the click-time all the way to the left to 0.01
and right click a little slower then you do with your left click
and keep right clicking and move the click-time up a "tiny" bit each time you test it
then as soon the the right click brings up the menu then set the click-time back a "tiny"bit till the menu does not pop up any more, you want the left and right click-time close to each other.

i set mine to Click Time,0.15 which seams to work good for me.

Last edited by informerman : 05-15-2012 at 01:42 AM.
 
Old 03-01-2013, 11:39 PM   #9
ezekiel66
Know-it-All
 
ezekiel66's Avatar
portfolio
v j
3D Artist
Germany
 
Join Date: Oct 2004
Posts: 422
Sorry that I re-activate this old thread. I just recently stumbled upon this problem again (doing some zbrush work again).

In one of the last updates (4R4 I think) they actually integrated a button that adresses the problem mentioned here. It can be found under Preferences -> Navigation, there is now a new button called "Enable RightClick Popup". Deactivate this button if you want to avoid the right-click pop-up to appear.

Just thought I'd let you know, tip might be useful to someone.
 
Old 03-02-2013, 03:56 AM   #10
informerman
Expert
 
informerman's Avatar
portfolio
EZ-Brush
dallas, USA
 
Join Date: Dec 2011
Posts: 879
Quote:
Originally Posted by ezekiel66
Sorry that I re-activate this old thread. I just recently stumbled upon this problem again (doing some zbrush work again).

In one of the last updates (4R4 I think) they actually integrated a button that adresses the problem mentioned here. It can be found under Preferences -> Navigation, there is now a new button called "Enable RightClick Popup". Deactivate this button if you want to avoid the right-click pop-up to appear.

Just thought I'd let you know, tip might be useful to someone.

there is a switch under that for zbrush 4 R5 called Enable right click pop up.
so you need the right click navigation ON
and Enable right click popup OFF
IF there both not set right you will get the pop up for the right click.

Last edited by informerman : 03-02-2013 at 04:06 AM.
 
Old 03-02-2013, 03:56 AM   #11
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:54 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.