Team Render Problem With Client Renders

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Display Modes
  06 June 2018
Team Render Problem With Client Renders

I just set up a Team Render configuration with the latest release of R19 Studio, including two iMacs and a Mac Pro. Everything set up well and appeared to be working when I began the render. Then, I noticed that the two clients were showing errors in their client windows. Plus, the renders from the two clients were not complete. What was occurring in the clients was that 1) the Book Generator was not generating books in the client renders although in the Master computer renders the Book Generator was generating books. Plus, 2) wall and floor textures were not being displayed in the building generated by House Builder although the textures were being displayed in the Master computer renders. All computers have R19.053 release installed.

Any suggestions what might be causing this and what to do?

Thanks!
 
  06 June 2018
Do the client machines have those two plugins installed within the Team Render Client's plugin directory?


Last edited by LukeLetellier : 06 June 2018 at 01:49 AM.
 
  06 June 2018
The plug ins are the same for the Master computer and the clients. It's not clear to me what or if any plug ins are necessary for the NitroMan Book Generator and House Builder. I checked in the Master plug ins folder and could not locate any plug ins labeled for NitroMan. It's not clear to me how NitroMan operates within C4D - whether it is a plug in or not. And if it is, how is it labeled in C4D?

Any other suggestions?

Thanks!
 
  06 June 2018
IS there a reason the generators need to be active rather than just making them editable? I would bake them out if you can do so with the rig , expression or plugin (whichever it is) isnt neccasary.

Last edited by JoelDubin : 06 June 2018 at 01:10 PM.
 
  06 June 2018
"I would bake them out if you can do so with the rig , expression or plugin (whichever it is) isnt neccasary."

It's not clear to me how I would go about "baking" them out. They are products of generators. So, how do you go about "baking" out the products of generators?

Please advise.

Thanks!
 
  06 June 2018
Are the generators animating in any way?

If not--then just click the make editable button on the generator and you have the geometry.

If its animated--you can export as an alembic file. Not sure exactly what your situation is. maybe post a clip? or the file.
 
  06 June 2018
Are you using magic book?

https://nitro4d.com/product/magic-book/

or nitro book case?

https://nitro4d.com/product/nitrobookcase/

If so then it is indeed a plugin and needs to be saved in your client plugin folders.

Seems to be the same with nitro floor which is part of the nitro room plugin set

https://nitro4d.com/product/nitroroom/
 
  06 June 2018
Originally Posted by JoelDubin: Are you using magic book?

https://nitro4d.com/product/magic-book/

or nitro book case?

https://nitro4d.com/product/nitrobookcase/
I'm wondering if either of these are now included with C4D by default in one of those asset libraries that I don't use but probably should. That could be where he's accessing them from.
 
  06 June 2018
I was wondering that too.

in THAT case...

Maybe he just needs to do a save projects with assets?
 
  06 June 2018
Save Projects With Assets - I did a save projects with assets. That did not seem to help with the problem.

Magic Book - No, I am not using Majic Book. I simply accessed these generators from the Content Browser. They both work fine if I do all the rendering in my Master computer. My plugins displayed in Plugins on the Master just show COFFEE & Python.

Here is one of the error messages from one of the Client computers of which there are several like this:

File "HouseBuilder - NitroMan", line 22, in main
TypeError: argument 1 must be c4d.BaseList2D, not None

Any suggestions what that means or what to do about it? Thanks!
 
  06 June 2018
Originally Posted by pacificm: Here is one of the error messages from one of the Client computers of which there are several like this:

File "HouseBuilder - NitroMan", line 22, in main
TypeError: argument 1 must be c4d.BaseList2D, not None

Any suggestions what that means or what to do about it? Thanks!
That's a generic Python error message, and there's not much we can do on our end to solve whatever it's referring to. Maxon would have to investigate it.

Have you tried exporting the House geometry that's generated by the House Generator as an Alembic cache, and using the alembic geometry in your scene instead?
 
  06 June 2018
I just tried making the Generators editable. So far, so good. It appears that may have done the trick.

Thanks for the help!
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:36 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.