UV seams and displacement issue

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  01 January 2013
UV seams and displacement issue

Hi guys ive got this problem: When rendering a displacement map with mental ray the mesh splits at the UV seams. Moving the seams just moves the issue to another spot on the mesh.

This is my workflow:

1. low poly mesh of a couch seat created in maya and exported as an obj to mudbox:


Heres a screendump of the UV map in maya. The UV borders or seams are where the splitting occurs at rendertime:



2: highres mesh in mudbox. (The detailing i've made is just to test the UV seams):


3: Displacement map extraction settings in mudbox (i use 4k resolution - forgot to set it right when i made the screendump):


4: back in maya i apply the displacement map from mudbox to the original low res mesh created in maya and set the subd approximation node like this:


5: When rendering i get this splitting and also some really weird reflextions/patterns on the surface:


What can i do to solve these issues?

Your help is very much appreciated!
 
  01 January 2013
The length of 1 is way too high on your subdiv approx, try a much lower value like 0.01 and see if it works out
 
  01 January 2013
Even at 0.001 theres no difference. I also tried to soften edges in a few different angles without result.
 
  01 January 2013
There is a known bug in mentalray witch causes this problem. There is an environment variable that was introduced some time ago. See here:

http://forum.mentalimages.com/showt...ht=displacement
__________________
www.renderwiki.com - www.openmaya.net
 
  01 January 2013
Originally Posted by haggi: There is a known bug in mentalray witch causes this problem. There is an environment variable that was introduced some time ago. See here:

http://forum.mentalimages.com/showt...ht=displacement


Thank you guys for replying! Great link! I'm too much of a newbie to really understand whats being written in that thread. As far as I can tell theres no hotfix from autodesk yet? I,ve gone through the lists of bugs in maya sp1 and 2 but couldnt find anything about this issue. Can you explain to me what you did to fix the problem?
 
  01 January 2013
you also need to make sure your UV seams align at the same angles (90) or you will get a seam. Read my blog post here:

http://polygonspixelsandpaint.tumbl...ost/19733351349
 
  01 January 2013
thanks cgbeige. because of you i've dived into the ptex thing. Seems very interesting and time saving. as im using mr for rendering ive got to edit the maya.rayrc file. I can open the file with nodepad and add the text but i cant save the changes. I get an access denied message. Do you know how to deal with this? Cant believe im getting blocked by Nodepad
 
  01 January 2013
Thanks for the helpful information Dave. Very interesting.
 
  01 January 2013
It's actually not a mental ray bug.

Displacement does not export correctly along seams. We argued with nVidia about it until we sent a displacement map for analysis and they were right, most software exports different values along the seam.

mental ray 3.10 has a way to mitigate this with the environment variable that takes the two values at seams and averages them.

The mental ray with the feature was mental ray 3.10.3.0

In the meantime might lean on Pixologic and Autodesk to improve their precision in exported maps. . . .
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
  01 January 2013
Originally Posted by Bitter:
The mental ray with the feature was mental ray 3.10.3.0


we stubled upond this issue (again) just yesterday.
David, do you know which version is in maya 2013.5?
__________________
my mental ray book my website
 
  01 January 2013
It's 3.10.1.4 I think in Maya 2013 SP2
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
  01 January 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:22 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.