MoText - color by word?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 08 August 2013   #1
MoText - color by word?

Hmm ... bug, limitation, or am I going mad? I want to use the mograph color shader to color a line of text by word and not by letter. When I put the shader effector (with gradient) in the motext's Word tab, I see the desired result, i.e., each word has a different shade of gray. But when I drop a material on the motext object with the mograph color shader in it, I get a single shade (white). If I drop the effector in the letter tab then it works properly.

So ... wassup with dat?

http://www.3danvil.com/temp/color_by_word_fail.c4d
 
Old 08 August 2013   #2
working fine here..
 
Old 08 August 2013   #3
Thanks, Paul. It seems it works if you put the material on the shader effector, but not if you put it on the text object ... which seems odd.
 
Old 08 August 2013   #4
Looking at this again it seems that the shader isn't doing anything in your scene, Paul. It's just the shader effector working directly. If you put the color shader in a colorizer, for example, you'll see that it's not working. That's a problem if you want to use different material channels, or the multishader.
 
Old 08 August 2013   #5
Thats how it works. An index is stored on each object and simply read and converted to a color via the mograph shader. Its was all very cruddy and primative but it still works and doesn't look like its been touched since I wrote it.
 
Old 08 August 2013   #6
Originally Posted by tapaul: Thats how it works. An index is stored on each object and simply read and converted to a color via the mograph shader. Its was all very cruddy and primative but it still works and doesn't look like its been touched since I wrote it.


But in this case it doesn't seem to work, i.e., the mograph shader isn't reading the per-word color values assigned by the effector.
 
Old 08 August 2013   #7
I'd say this is a bug, you can clearly see it if you make
the MoText Object editable, then the colorizing per word
is visible and renderable.

Last edited by typografschaft : 08 August 2013 at 01:52 PM.
 
Old 08 August 2013   #8
Originally Posted by typografschaft: I'd say this is a bug, you can clearly see it if you make
the MoText Object editable, then the colorizing per word
is visible and renderable.


Agreed. I'll report it.
 
Old 08 August 2013   #9
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:09 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.