Vray GI and Reflection issue

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

Thread Tools Search this Thread Display Modes
  08 August 2015
Vray GI and Reflection issue

Hello all!

I'll make this quick. I'm trying to render three layers of an object in Vray.

1. Background
2. Sphere
3. Base

The issue I am having is that when I comp them together I noticed that the GI and the Reflections don't have all the information compared to the render where everything is all in one layer.

Left image is how it should look (all objects in one render). Right image is with three separate layers.

Here is comparing the GI

Here is comparing the Reflections:

Here is comparing everything in one render layer vs three render layers merged together:

I have primary visibility disabled on the objects I do not want in the layer. This seems to be effecting these passes.

I have tried adding Vray Object Properties to every object and making sure effect GI was on but no luck.

I have a feeling it is the light cache not picking up the (primary visibility off) objects but I am not that familiar with Vray so it might not be the case.

I would like to note that I do know very well how to composite images. This is an issue with how they are being rendered out of Vray.

Any help would be great!

Thank you!

Last edited by bunnster22 : 08 August 2015 at 11:35 AM. Reason: Added links to images
  08 August 2015
What software are you using? In 3Ds Max, you do this by unchecking "Visible to Camera" in the object properties (Not vray object properties, just regular object properties). that makes the makes the object still appear to reflections, GI, shadows, etc., but be invisible to only the camera.
I whatever primary visibility is, it makes the object completely disappear from all render calculations, not just from the camera.
  09 September 2015
I am using Maya 2014. This is the "Primary Visibility" I am talking about. It's just a normal Maya setting in a render layer. To my knowledge it should only be removing the object from "primary" vis and not removing it for reflections or anything else.
  06 June 2017
I'm having the same issue now and so far the only way I have been able to fix it is to change the bounce engine from "Light Cache" to "Brute Force". *It seems like the light cache engine can't see objects with primary visibility turned off. *Is this a bug or is there some light cache option I am missing?
reply share thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Society of Digital Artists

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump

All times are GMT. The time now is 07:05 PM.

Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.