Viewport performance

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 05 May 2013   #1
Viewport performance

I tried to solve the problem by myself but I'm pretty helpless. The viewport is unbelievable laggy when I try to create large scenes or small ones with high-res textures. I'm currently working on a high res truck (over 4 million polys) with high res textures and the viewport performance is really crappy (4-7 FPS).

I reinstalled max, installed the latest updates and at least I reinstalled windows. But nothing helped.

Here are my system specs:
Intel Core i7 2600k
Geforce GTX 560 (2GB)
16 GB Ram
 
Old 05 May 2013   #2
You could try a GPU utillity such as EVGA Precision to check if your graphics memory is running out. I've heard that these utilities are not 100% correct when reporting memory, but they should be pretty close.

If you are running out of memory, try using lower res images when modeling. Another solution would be to hide parts of the truck while modeling using layers.

If you can, switch to max 2014 as it has better performance in the viewport. Also, the layer display modes now work inside Nitrous, which can help. You could put some layers in wireframe mode so they don't disappear but at the same time they don't eat graphics memory with their textures.

Low FPS can also happen when you have complex modifiers or rigs. For example, you can optimize turbosmooth to have only a few iterations in the viewport and more iterations when rendering.
__________________
Check out my work: www.TractorMedia.ro
 
Old 05 May 2013   #3
The question is whether you really need to see all the textures visible in full resolution all the time?

If you're using Nitrous (2012-2014) there's maxscript access and some utilities (in 2014 the controls are in the UI) to limit the texture display size in the viewport that can help you speed things up quite a bit.
 
Old 05 May 2013   #4
The texture tweaker looks really interesting. I'll give it a try. Thank you.
 
Old 05 May 2013   #5
The viewport performance is a bit better with the texture tweaker (10 FPS now).
But I think thats not the main problem.

3ds max is using a lot of video memory. Currently nearly 11 GB RAM. A few years ago I just had 4 GB RAM in my workstation and 3ds max worked well. Now it slows down the whole system. :(

I'm using Windows 7 64 bit and the 64 bit version of 3ds max.
 
Old 05 May 2013   #6
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:57 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.