Vray matt shadow Issue

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  09 September 2012
Vray matt shadow Issue

I try to render a moving object in a None moving environment so i render the environment in a pass and the moving objects in another pass. the problem happen when i render the moving objects. the matt objects cause a shadow problem as it don't prevent shadows.i attached images for more information.
Attached Images
File Type: jpg Render Final Compared.jpg (90.3 KB, 32 views)
File Type: jpg Fg Alpha.jpg (94.0 KB, 24 views)
File Type: jpg BG+FG.jpg (73.3 KB, 26 views)
 
  09 September 2012
If you want it to go back together correctly as you see it in your RGB you need to either render the shadows of the moving objects into the environment as well as the static shadow or composite your render elements back together.

To get just the environment, turn your animated objects visible off to the camera. They will still cast shadows and reflections onto your environment but the animated object will be invisible. Then, render a separate pass for the animated object as you have done already and just put it back over the top.

At the moment your two shadows are in essence separate, and therefore you are relying on compositing them through correction rather than letting the render combine them for you, hence why one is darker than the other.

Last edited by Frubes : 09 September 2012 at 08:36 PM.
 
  09 September 2012
thanks for replaying
i agree with you completely. the point is i bake the gi in the BG pass for fast render times so it won't work correct if animated objects in the BG pass even if not visible.
another thing i used the same method before in max 2011 and vray 1.5 rc5 and worked perfect
it was my main render way.that is why i think there is a soloution for this problem that can render the Animated objects pass with correct shadows.and also the shadow don't cast correct that mean there is something wrong.
 
  09 September 2012
If you render out all your passes separately for both FG and BG you could have more control over recombining them in the comp. Merge the AO and shadow passes together on their own, masking, etc.

Also looks like your density and color are getting weird, because even the part of the shadow that's not doubled up, doesn't look right.

Maybe try the app specific forum?
 
  09 September 2012
the strange result just came out in this fast test. but normally the problem is in the double shadow area.i tried the vray forum and the area and i searched the web but no result.and as i said the problem is that this way is much faster and the less to work by than render out each pass (Diff reflection shadow )to fg alone and BG alone. and the old way was working perfect .but out of no where this problem came out.that is why I'm searching for a way to solve it.and i'm also looking if any one have the same problem????
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:30 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.