Issues with the new design

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  11 November 2013
Issues with the new design

Sorry if late for the party, etc, but just logged in today, and found the site has a new design.

I am using a tablet, and will seldom use a destop again. Here are some of the issues I have encountered in the CGPortfolio site (Chrome, Safari and Dolphin all have problems):

  1. Page loads fine, but projects thumbnails do not (Safari and Dolphin).
  2. In Chrome, if you navigate to some other tab, and again to the portfolio one, the page starts loading again (this happens to the forum pages as well).
  3. Infinite scroll: this seems like a cool idea, but in reality it's a pain, since projects need to load all over again if you click on a thumbnail. Or in the Chrome case explained above, you need to click on the "Load more" over and over again, since it only loads the first batch initially.
  4. Pinch / zoom does not work: this ignores one of the most comfortable features of working with a tablet.
  5. In Safari, clicking on the top Profile Image> Drop menu for settings, links to a nonexisting page (http://.cgportfolio.org), so you cannot access your settings.


Thanks.
__________________


tumblr ░░░░ facebook

Last edited by joana : 11 November 2013 at 02:03 PM.
 
  11 November 2013
Thanks for letting us know! I'll make sure our tech wizards see this, and please don't hesitate to let us know of any other issues!
__________________
leighvanderbyl.com
 
  11 November 2013
Issues I've seen so far:

- on the main page, the user avatar is missing in the main header
- on the Portfolio page, sometimes clicking on a project's comments symbol (which should direct you to the original thread) will result in a 'you do not have permission to access this page...' message. It seems to happen with closed threads mostly, some closed threads still open fine
- when clicking on the avatar on my own page (opens 'Edit Avatar' page), this is displayed as rule for image size: 'Note: The maximum size of your custom image is 0 by 0 pixels or 0 Bytes (whichever is smaller).' Zeros should be replaced with meaningful numbers
- portfolio > about > contact: e-mail and website links do not work
- just saw that the 'view portfolio' button grpahics under users' avatars in forum threads are missing, and clicking results in a 'file not found' message site

Other than that, it's great to see the improvements finally, congrats! It's so much better now with larger image previews. I'd still have some suggestions but I bet you don't want to hear!

Last edited by pokoy : 11 November 2013 at 08:42 PM.
 
  11 November 2013
I think the design looks good! I'm using Firefox on Win7 and other than the comments issue, it seems to run smoothly.

Also, are the portfolio view counts calculated differently now? I noticed when I refresh the browser, it goes up by one. I don't think the old one counted views from the user. Also, it looks like the view count has roughly doubled for everyone? Is it also counting search engine bot hits?
__________________
 
  11 November 2013
I'll just add that enlarging a 100x100 forum avatar to 250x250, on the Portfolio main page, looks really crappy. Even at 193x193, on the user's Portfolio page, the image looks fuzzle-messy. Bleh.
 
  11 November 2013
Unhappy

The "Latest Work 3D" gallery is now broken. Most of the threads are locked, with absolutely nothing inside, and the following at the top of the page:

Warning: Invalid argument supplied for foreach() in /showthread.php on line 826

Warning: Invalid argument supplied for foreach() in /showthread.php on line 929

I'm using the latest version of Firefox on Windows 7 x64.
 
  11 November 2013
Hi all,

THANKS for your feedback. It's very much appreciated.

We've been fixing bugs all day, so hopefully a good number of the mentioned ones are now non-issues. I'll try and address each in turn:
1. Page loads fine, but projects thumbnails do not (Safari and Dolphin).
--FIXED
2. Chrome, if you navigate to some other tab, and again to the portfolio one, the page starts loading again (this happens to the forum pages as well).
-- I'm not getting this behaviour, we might have fixed it. Can you recheck please?
3. Infinite scroll: this seems like a cool idea, but in reality it's a pain, since projects need to load all over again if you click on a thumbnail. Or in the Chrome case explained above, you need to click on the "Load more" over and over again, since it only loads the first batch initially.
-- Would you prefer a paging interface?)
4. Pinch / zoom does not work: this ignores one of the most comfortable features of working with a tablet.
--We will look into this one. It might be the case the the responsive design comes at the price of no pinching)
5. In Safari, clicking on the top Profile Image> Drop menu for settings, links to a nonexisting page (http://.cgportfolio.org), so you cannot access your settings.
--Can you try this again and tell me if it's fixed or broken please. If it's still not working, please try logging out then back in



6. on the main page, the user avatar is missing in the main header
-- FIXED
7. on the Portfolio page, sometimes clicking on a project's comments symbol (which should direct you to the original thread) will result in a 'you do not have permission to access this page...' message. It seems to happen with closed threads mostly, some closed threads still open fine
-- We will address this shortly
8. when clicking on the avatar on my own page (opens 'Edit Avatar' page), this is displayed as rule for image size: 'Note: The maximum size of your custom image is 0 by 0 pixels or 0 Bytes (whichever is smaller).' Zeros should be replaced with meaningful numbers
-- Can you send me a screenshot of this please. I can't replicate that behaviour - bencastles@ballisticmedia.net
9. portfolio > about > contact: e-mail and website links do not work
-- Can you send me a screenshot of where this link is please
10. just saw that the 'view portfolio' button grpahics under users' avatars in forum threads are missing, and clicking results in a 'file not found' message site
-- Sorry to ask for another screenshot, but if you circle where it should be that would help me find it!

11. Other than that, it's great to see the improvements finally, congrats! It's so much better now with larger image previews. I'd still have some suggestions but I bet you don't want to hear!
--We would love your suggestions. Fire away to my email address: bencastles@ballisticmedia.net


12. Also, are the portfolio view counts calculated differently now? I noticed when I refresh the browser, it goes up by one. I don't think the old one counted views from the user. Also, it looks like the view count has roughly doubled for everyone? Is it also counting search engine bot hits?
-- The portfolio views are coming from the DB. I'll have another look at how that works. Regarding incrementing the number do you think it should reflect the number of users who looked at a portfolio, not every page they looked at?

13. We will work on a I'll just add that enlarging a 100x100 forum avatar to 250x250, on the Portfolio main page, looks really crappy. Even at 193x193, on the user's Portfolio page, the image looks fuzzle-messy. Bleh.
-- The avatar system needs some work. What we see now is a temporary solution. Updating avatars to 193x193 looks much better than 100x100 if that helps!


Thanks again,
Ben
 
  share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 04:08 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.