"Render elements" work with alpha opacity?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Display Modes
  03 March 2006
"Render elements" work with alpha opacity?

Hey all,

this is an old subject, but I searched it and only one thread was directly relevant, and there was no solution there, and the thread was "closed automatically". So, here I go again.

When using "Render elements" to render light and zdepth passes, my alpha opacity planes appear as solid planes. Big problem, causes sucky compositing.

I'm rendering a big city scene with lots of planes, so rendering every alpha plane seperately is not an option.

Any suggestions?

Thanks,
- Jonas
__________________
 
  03 March 2006
http://www.adamwalkerfilm.com/AWFtools.htm

the lowest tool called z-auto maybe that help. haven't tried it yet,

i had the same problem.
__________________
www.onesize.nl
-----------------
Yeah right! sure...
 
  03 March 2006
Thanks, I'll have a look at that!

But it's not just Z-Depth, it's also lighting passes, which are also rather important...

Cheers,
- Jonas
__________________
 
  03 March 2006
a friend of mine sad he sloved that problem by using mental ray...
cos it raytraces it, but i havent checked that
__________________
www.onesize.nl
-----------------
Yeah right! sure...
 
  03 March 2006
All you have to do is replace your diffuse maps with a falloff set to distance and use the values from your render elements pass for the zdepth, be sure to disable antialiasing. For the lighting pass make the diffuse map a solid white color. This will generate the passes without using render elements.

-Eric
__________________
"The Evil Monkey hiding in your closet."
 
  03 March 2006
Thanks for the answers! But....

Originally Posted by PiXeL_MoNKeY: All you have to do is replace your diffuse maps with a falloff set to distance and use the values from your render elements pass for the zdepth, be sure to disable antialiasing. For the lighting pass make the diffuse map a solid white color. This will generate the passes without using render elements.
Yea well, workarounds like that are aplenty, I usually turn off diffuse map, give the material a solid white color (self-illuminating) and add a black distance fog.

But, the scene being so complicated, with hundreds of materials, that's not an option.

So.... thanks for the reply , but it's still not the solution I was looking for. Anyone know if Max 8 is doing it?

I'd file this as a bug, the render elements feature is completely useless for large scenes with opacity maps.

I'll have to try out Mental Ray.

Cheers,
- Jonas
__________________
 
  03 March 2006
Dunno if this works. Have you tried out rendering matte elements instead of alpha elements?
 
  03 March 2006
Hmmm, not sure how I would do that...

When selecting z-depth or lighting pass, I can't choose whether they should render as mattes or alphas. Mattes and alphas are different elements alltogether.

Thanks,
- Jonas
__________________
 
  03 March 2006
I know that they are different elements, but it works(well kinda). I had a huge scene with tons of particles, most of them camera facing simple planes with opacity and all that crap. neither the z-depth nor the alpha render element worked in a proper way,

my z-element looked like this



And kinda like that the alpha pass, too.

So I faked around the z-pass with a distance falloff material and to mask out the particles in the compositing I assigned a matte element to all the surrounding geometry which resulted into this



which I used as a travellling matte in AE.
A matte element can be activatedin the render ellements menu, scroll down the list. You have to assign an G-buffer ID for the scene objects or an FX ID for the materials.

Hope this helps
 
  02 February 2007
Hi Jussing,

Did you come to a solution for this?

thanx in advance!
 
  02 February 2007
Well, not a really practical solution, no.

Scrimski's solution with a distance falloff is the closest I can get to a working setup, but even that is a bitch if you have lots of materials.

(sorry Scrimski, I never got around to say thank you for your suggestion, and I had totally forgotten this thread!)

Cheers,
- Jonas
__________________
 
  02 February 2007
Hi, i have seen a checkbox called Transparency propagates Alpha channel under the Andvanced Rendering Options Rollout in the new Mental Ray-Arch&Design material that turns on alpha Opacity for transparent materials.

From reference file:
It Defines how transparent objects treats any alpha channel information in the background. When on, refraction and other transparency effects propagate the alpha of the background “through” the transparent object.

Mabye that can help u if u whant to use MR.

Good luck.
 
  02 February 2007
Wow, I had this problem for the past 2 weeks (using fog with opacity maps in MR)

Searching this forum again was my last attempt and just today SkynetOne posted the solution

I love you
__________________
jonmonaghan.com
 
  02 February 2007
SkynetOne..

I'm new to Mental Ray, which version of Max you're talking about?
 
  02 February 2007
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:00 AM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.