3ds max 2013 viewport background image : odd behaviour

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  07 July 2012
Unhappy 3ds max 2013 viewport background image : odd behaviour

Hi,

I recently switched to 3ds max 2013 and came across a very strange issue when putting an image in the background :
The problem is that if I switch between "Use Environment Background" and "Use Files" the background image doesn't match.

Explanation in images :

1. This is the viewport display when checking "Use Files"


2. This is the viewport display when checking "Use Environment Background". See how the image is streteched horizontally and cropped !

3. And this is the rendering, that matches the first viewport display (from file).




I tested the very same scene in max 2012 and it behaves normally : the displayed background is consistent wether I use environment or a file.

Is that a bug, or did I miss some new hidden setting in max 2013 that could cause this ?
Also, I noticed that my background image was very badly pixelated. I could partially solve this by using : NitrousGraphicsManager.SetBackgroundTextureSizeLim it 6000 true
But only partially because this settings affects the display when environment background is set, but has no effect when using a file.

Any help about these issues would be greatly appreciated.

Thank you.
Attached Images
File Type: jpg 2013_vpbg_env.jpg (81.1 KB, 129 views)
File Type: jpg 2013_vpbg_fromfile.jpg (81.4 KB, 133 views)
File Type: jpg 2013_vpbg_rendered.jpg (86.3 KB, 130 views)
 
  07 July 2012
update :

tested this on another machine, also running max 2013 with product update 3 and the result is the same : the environment background is displayed stretched in the viewport.

If I switch to direct3d, it works ok. So I guess this is a bug directly related to Nitrous... Although the fact that this dosen't happen with nitrous under max 2012 leaves me perplex.

Last edited by edgy_k : 07 July 2012 at 07:22 PM.
 
  02 February 2013
Same problem here, just found it myself. Using a custom image as a background it automatically fills the viewport and does not respect the frame size/safe frames. This is the bug and it appears to be with Nitrous.
__________________
Alex York
Founder of Atelier York
Bespoke London-Based Architectural Visualization
 
  02 February 2013
Yes, it is definitely a bug.
I contacted autodesk support about this issue back in august 2012. They could replicate the problem and said they would look into it. No news since then. Maybe it will be fixed in release 2014 ? Unless they brake something else in the process...
 
  02 February 2013
Yes it's a bug in 2013, ithink it's still there in PU6 but i'm not sure
Anyways, you should update to PU6

BTW
AFAIK the distortion in the viewport only happens when you have safe frames display enabled. turning them of, gives correct viewportdisplay of the ENV map
__________________

PowerPreview: High Quality Nitrous Previews for 3ds Max 2012|2013|2014

[ Free Download (ScriptSpot) ]

Home of The Frogs | Online Portfolio
 
  02 February 2013
Originally Posted by spacefrog: Yes it's a bug in 2013, ithink it's still there in PU6 but i'm not sure
Anyways, you should update to PU6

BTW
AFAIK the distortion in the viewport only happens when you have safe frames display enabled. turning them of, gives correct viewportdisplay of the ENV map


I'm on PU6 so it's not fixed in that. And turning off Safe Frames does indeed "fix" the problem but I need them on so I can match my BG plate. The only way around this I've found is to use the Env background rather than a custom image, or by using manual plates with geometry (through a script maybe).
__________________
Alex York
Founder of Atelier York
Bespoke London-Based Architectural Visualization
 
  02 February 2013
Report it to AD
 
  02 February 2013
Originally Posted by alexyork: I'm on PU6 so it's not fixed in that. And turning off Safe Frames does indeed "fix" the problem but I need them on so I can match my BG plate. The only way around this I've found is to use the Env background rather than a custom image, or by using manual plates with geometry (through a script maybe).


You could turn on safe frame temporarely and rescale the viewport (by dragging the sides) so it matches the safe frames aspect ratio and then turn off safe frames again.

Originally Posted by Swahn: Report it to AD


-->

Originally Posted by edgy_k: Yes, it is definitely a bug.
I contacted autodesk support about this issue back in august 2012. They could replicate the problem and said they would look into it. No news since then. Maybe it will be fixed in release 2014 ? Unless they brake something else in the process...
 
  02 February 2013
Originally Posted by CHRiTTeR: You could turn on safe frame temporarely and rescale the viewport (by dragging the sides) so it matches the safe frames aspect ratio and then turn off safe frames again.



-->


not really accurate enough - i'm doing very precise alignments to photos that require this to work as it did in 2012 and earlier, but thanks for the suggestion.
__________________
Alex York
Founder of Atelier York
Bespoke London-Based Architectural Visualization
 
  02 February 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:09 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.