CGTalk > Software > Maxon Cinema 4D
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 12-16-2013, 12:34 AM   #1
Rusherific
New Member
Devin Earthman
Berkeley, USA
 
Join Date: Sep 2006
Posts: 12
Black textures from Bake Objects

So I'm new to the whole baking objects thing in Cinema, but is really important for my current project. It works mostly as expected however several objects kept coming out black after baking the illumination. The thing is that I've checked that all normals are aligned and facing the correct direction. In fact I have to reverse the normals to the "wrong" direction in order to get cinema to bake these certain objects properly!?? While other objects in the same scene bake with their normals facing the right way. So, it's not that I'm stuck here, but it's obviously a pain to have to set a scene up to bake GI overnight and find half the textures are black and then go through and test each one to see what's messing up so it'd be nice to know if I was doing something wrong for the future. Note it's not GI related either as I get the same results testing my scene with just direct lighting too. It also seems to not make a difference how my original textures are applied (front/back/both/UVW/flat etc).

The googling I did lead me here where there was talk of this issue, but with imported models. I'm having this same issue but with very simple primitive objects made in C4D -- I'm talking planes and cubes made editable!
 
Old 12-25-2013, 04:25 AM   #2
CharlotteBartlett1983
New Member
 
CharlotteBartlett1983's Avatar
portfolio
Charlotte
London, United%2BKingdom
 
Join Date: Dec 2013
Posts: 5
Hi

I have never seen that unless normals are incorrectly set up. Or you have a duplicative mesh turned off in viewpoint, and turned on in render.

As a side note though, I don't use bake object and for illumination - I get better results using the bake texture tag. Can you post an example scene showing it?
 
Old 12-25-2013, 04:25 AM   #3
CGTalk Moderation
Expert
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,478
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:30 PM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.