ZappLink error with 4R5 to Photoshop

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 01 January 2013   #1
ZappLink error with 4R5 to Photoshop

I have just started the plunge of upgrading from old Zbrush 4.0 (before 4R2) to the latest 4R5. I am excited about the tons of new features but I wanted to make sure the critical older functions still worked.

So far one of the critical ones is getting me an error message I cannot get around. Using ZAPPLINK to send my views of my painted model to Photoshop to bake on the material system to the texture.

Its a new Zbrush 4R5 is installed in its standard location (I removed the old version of Zbrush software which was installed on another hard drive of my PC). Photoshop CSS5 is still installed and has not been touched as part of my 4R5 install. Its also installed on another drive of my PC...but in the Zbrush 4.0 install, the interlink worked fine.

I now get an error in 4R5 when I tell ZappLink to switch to Photoshop. I get the following error window pop up....

Window title: "Zscript Note: Interface item could not be found..."
Details:
SCRIPT: ZAppLink_4.0.txt
ERROR: 3842
IN: [IGetFlags,internalLayerID]

That I see a reference of the older 4.0 makes be worry that somewhere there is a reference to the older Zbrush but I have no clue where to address this. I did tell the ZAppLink in the new 4R5 to point to the new PS executable but that has not fixed the problem.

Anyone have a solution to this? Is there something I need to do with Photoshop as well?
__________________
Toysoldier Thor
Digital Artist & SecondLife Creator
http://ToysoldierThor.com
 
Old 01 January 2013   #2
So to answer my own question.... for those of you that will also encounter this problem when upgrading from an old version of Zbrush to 4R5.

The ZAppLink_4.0.zsc that is installed in the startup\Zplugs folder for version 4R5 must have some kind of bug/incompatibility with 4R5. Just because Pixologic included it in the default install doesn't mean it works.

There is an update of this exact file for version 4R5 available from the plugins download page for 4R5 users. Its dated dec 27, 2012 instead of the older date of the same file in your install.

Download this file from the site and REPLACE the old file with the new file.

WARNING.... DO NOT SIMPLY RENAME THE OLD ONE on the same folder. For some weird reason, Zbrush seems to have an affinity to the file in that folder even if you rename it and it will use it. So.... over-write the old with the new.

Restart 4R5 and all will work right away.
__________________
Toysoldier Thor
Digital Artist & SecondLife Creator
http://ToysoldierThor.com
 
Old 02 February 2013   #3
Thanks for the solution - fixed it right away.
 
Old 03 March 2013   #4
Thanks for sharing
__________________
angelnavarroart.com | blog
Available for work!
 
Old 03 March 2013   #5
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:13 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.