nHair follicles following mesh surface, but not rotating with it.

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
  2 Weeks Ago
nHair follicles following mesh surface, but not rotating with it.

I have a problem with nHair follicles. If I rotate the polygons of the base mesh, the follicles move correctly with the surface, but keep pointing in the same direction for some reason (as crudely illustrated below). The follicles should be rotating to follow the normals, but aren't for some reason. Note that I'm talking about the follicles them selves, not the dynamics output curves.

The follicles and nHair system are made using the Make Curves Dynamic option on groom curves coming from a plugin. The exact same workflow on the same character has worked flawlessly before, but suddenly I just can't get it to work anymore.

Any ideas?

 
  2 Weeks Ago
It sounds like your input hair curves are parented to your base object. Instead the hair curves should not be attached or parented to the object. Then when doing make curves dynamic also have the surface selected and use the "attach curves to selected surfaces" option in the option box so that the follicles then get attached to the closest point on surface.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:52 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.