Baked texture looks different than the rendered

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2013   #1
Baked texture looks different than the rendered

Hi,

I'm baking textures to my model. First I create a test-render, before doing the batch bake with the same mental ray settings. For example:



After, whem I'm doing the batch bake with the same settings, the result is very different, than the prerender.
After batch bake:



I did not changed anything in the mental ray settings. What causes this? Please help...
Thanks!
Attached Images
File Type: jpg prerender.JPG (33.1 KB, 85 views)
File Type: jpg batchbake.JPG (39.3 KB, 82 views)
 
Old 02 February 2013   #2
Hmm, there are some contour lines, in the borders of the UV maps (?)

Another example

prerender


batch-bake, baked texture assigned to object


Still no idea, how to prevent this...
Attached Images
File Type: jpg noContour.JPG (34.7 KB, 75 views)
File Type: jpg withContour.JPG (49.0 KB, 76 views)
 
Old 02 February 2013   #3
try disabling texture filtering for your file textures.
 
Old 02 February 2013   #4
You should use Fill Texture Seams = 3 (or more) for baking
__________________
Pavel Ledin aka Puppet
 
Old 02 February 2013   #5
These artefacts are, as cgbeige said, from texture filtering. Fill Texture Seams is nice solution, but more than 2 is too much in my experience. There might be some artefacts if this setting is too high.
Try to set background color on baked texture as close as you can to baked parts. You can also bake with alpha (coverage) and extend color from border by yourself in photoshop.
 
Old 02 February 2013   #6
try disabling texture filtering for your file textures
- unfortunately the result is almost the same

You should use Fill Texture Seams = 3 (or more) for baking
- I use 3, so it was also set when I baked the textures

Try to set background color on baked texture as close as you can to baked parts. You can also bake with alpha (coverage) and extend color from border by yourself in photoshop.
- This could work, but in most cases I have complex textures, and this would highly increase the work with the texture baking.

Thank you for the ideas, I will inform you if I get the solution somehow...
 
Old 02 February 2013   #7
unfortunately I have still no results, the problem still exists :(
 
Old 02 February 2013   #8
I'm not super familiar with texture baking in mental ray, and I won't say I know entirely how it works either, but an idea that comes to mind, is that mental ray may be trying to bake additional data into the maps. This wouldn't make a whole lot of sense with the contours, however, so it's just a thought. If possible, try using maya software bake? I know that the software bake has produced fine results the couple times I've had to use it.
 
Old 02 February 2013   #9
Hello,

I tried also the Maya renderer, but the result was much more different, than the mental ray. I suppose I have to recreate and reset every lighting option/settings!?
And the rendered images were not so realistic with maya software (I did not changed anything in the scene, just select the maya renderer instead of mental ray)

My problem is with the texture seams... I need to 'remove' them somehow. I made a batch bake with 256 x 256 resolution, textures seams was set to 10, but unfortunately the problem still exists. What value should I choose?

I tried something, which worked: manually move every border UVs to a correct place, inside the texture (I did not left UVs in the borders). But this kind of 'solution' slowes the process, and I hope Maya 2012 can offer we a better solution also...

Does?
 
Old 03 March 2013   #10
Ok, now I found the solution...


In my Maya 2012 x64 the 'Fill texture seams' option has no effect. If I set it to 1, or 10, the result is the same. It doesn't matter.

The origin of the problem is, that if I set the 'Bake optimalization' to Multiple objects, then it just ... WORKS!!!

If I set it to Single object, it has no effect.
 
Old 03 March 2013   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:42 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.