MASH Blend Node + Falloff Helper Bug?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Display Modes
  1 Week Ago
MASH Blend Node + Falloff Helper Bug?

I am going through the MASH toolkit features one by one trying to see what it can do and hopefully find it useful. It looks like it has a lot to offer.

I was playing around with the MASH Blend Node.
I create a flat plane.
Duplicated it.
Offset the duplicates vtxs upwards.
Applied the "MASH Blend" on the first plane.
Connected the second one as a target.
Applied a "falloff object" to animate a wipe-on of the blend.
Unfortunately I started noticing some *spikes* where the "smooth" wipe-on was suppose to happen. Like some vertices were not being affected properly by the "falloff object".

I tried it with some slightly more complex models.
Like a Cube that was **Polysmoothed**.
Duplicated and modified the shape a bit just like the plane in the previous example.
Applied the "MASH Blend" on the first Cube that was **Polysmoothed**.
Connected the second modified Cube as a target.
Applied a "falloff object" to animate a wipe-on of the blend.
Again random spikes!!

Tried it on a sphere and it worked...

I went back to the cube test, deleted all history. Did a **REORDER** of the vertices on both BASE and target.
Applied the "MASH Blend" and "falloff object" again.
Got *less spikes* but again it was still *NOT perfect*.

Tried all of the above with a "Map Helper" poly-plane and "UV mode" instead of a "falloff object" and this way it worked.

These issues occur in Maya 2017.4 and 2018.3. So it looks like it not a new issue.

It looks like there is a pretty obvious BUG with the MASH Blend Deformer when used with a "falloff object". It only works in simple spheres or similar smooth primitive without scattered vtx order (such as what you get when you apply a polysmooth for example) from what I have tried so far.

The documentation with MASH is not the greatest. It is a bit incomplete and in certain parts it is inaccurate from what I can tell. Which is not very encouraging. I really hope it's not more of the same of what Maya provides.
 
  1 Week Ago
in your falloff object change the component type to vertex


Last edited by Onouris : 1 Week Ago at 10:57 PM.
 
  1 Week Ago
Thanks for your reply. I was playing around with it again a few minutes before you posted this and figured out that it was exactly that. Interestingly enough... even the demo videos, if you look at them carefully Ian Water does not have that set to vertices. And it does default to faces.
 
  1 Week Ago
not sure but i think in the very first iteration of Mash there wasn't a "face" mode in the fall off object, so by default itwas always operating on vertex.
 
  1 Week Ago
>i think in the very first iteration of Mash there wasn't a "face"

That is also correct. In one of the older videos the option to switch component mode does not exists. In one of the later ones (the one with the torus and particles) it does. And he has it set to faces also. Some of those video could be a lot better. I personally would prefer better documentation than listening to that guy talking and giggling because he thinks he's funny or something.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:34 AM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.