Convert to Editable Poly PROBLEM

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2013   #1
Exclamation Convert to Editable Poly PROBLEM

Hi, I have just created an account here since I couldn't find a solution to my problem, so here it is. I am working on a model right now and everything was fine until it somehow got corrupted and started crashing with a lot of things I did -NURMS subdivision, even using the Loop tool with edges- so I decided to just export what I had in a new file in hopes it would work itself out. The problem is, when I try to convert the imported mesh to edit poly, some polygons get weird and don't get lit well, they generally dont mesh with the rest of the model. Here are some pictures of it.

Here is the model in editable mesh when I just imported it


And here is the model when I convert to editable poly


I tried almost everything...I mean I'm not a pro so I'm kinda stuck here , the polys are not flipped, I tried that, I also tried recreating them but they stay busted.

Also, even when I apply a smoothing group, all the model stays jagged

If anyone could find a solution to my problem (or the first one where it crashed for reasons unknown) I would very much appreciate it.

ps: Sorry if there is already a thread to this problem, didn't find one, wasn't too sure of what to search for.
 
Old 02 February 2013   #2
Try merging the file into a new max file and see if that works.
Make a new blank max file then go to merge and merge in your corrupted file.
This sometimes works.

Good luck
__________________
Luke
Web site

3d Max 2012 Win 7
Intel Corei5 8g Ram

 
Old 02 February 2013   #3
Try adding an Edit Normals modifier, select all the normals and reset and see if it fixes it.
__________________
The Z-Axis
 
Old 02 February 2013   #4
I did what darthviper107 said and it worked! Thanks a lot, you saved me quite a bit of time!
 
Old 02 February 2013   #5
Try to export it as .obj, then import it in to a freshly reset 3ds max scene
 
Old 02 February 2013   #6
All else fails, grab all the faces and do a detach to object. That will usually clean out any bugs. Just be sure to delete the empty node that was left.
__________________

www.nickmcelmury.com

"The best things in life are either illegal, fattening, or take too long to render."
 
Old 02 February 2013   #7
Turn to Poly modifer + collapsing stack usually fixes this kind of errors.
__________________
Scripts :: linkedin
 
Old 02 February 2013   #8
Looks like some of the polys have ended up facing the wrong way. That's not legal geometry in editable poly mode (if they're welded) and can cause crashing and all sorts of nastiness when converting.

As darthviper107 says, resetting the normals should sort it out.

Or worse, you might have duplicated and flipped polys on top of each other. Back to back. That can be bad too and can be harder to fix. Try selecting and moving the polys and see if they come away, or are only attached by some verts. The Xview option under the viewport label menu might help find them if that's the case.

I'd recommend turning the default viewport lighting to 1 light so you can see which way the polys are facing while working and ideally turn on back face culling so they're invisible if facing away from the viewport. That makes it much more obvious if you're doing something like this.
 
Old 02 February 2013   #9
xview is your friend

hopefully
 
Old 02 February 2013   #10
Xview is a bit hit and miss IMO. It often highlights things that aren't errors. It mis-identifies the corner verts of cubes as T-Verts when they aren't what I'd say were T-verts. And doesn't actually have options for some things that would be really useful (like back to back polys). it certainly can help. But it's not great in all cases.

It does have an option for face orientation though, so it might help here.
 
Old 02 February 2013   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:16 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.