CGTalk > Software > Autodesk 3ds max
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 10-10-2012, 09:34 PM   #1
Hannamations
Veteran
portfolio
Hannah Benbow
Animator
USA
 
Join Date: Jan 2011
Posts: 59
Strange Texture Issue When Rendering...

Has anyone ever had this happen to them before?

I have a handful of hay bales that I'm trying to render. But each time I hit the render button only one of them changes to a different texture. It looks like the original texture on the hay, but larger...

It's driving me crazy!!

Help?

 
Old 10-10-2012, 09:37 PM   #2
KellyM
Expert
 
KellyM's Avatar
Kelly Michels
3ds Max Beta Manager & Senior Autodesk MED QE
Autodesk
Kingwood, USA
 
Join Date: Jan 2004
Posts: 387
Can you post a scene file?

What version of 3ds Max?

Does it occur in a camera view also?

How are the bale's mapped?

What renderer?

Does it ever occur in the VP?
__________________
Twitter: @Kelly_Michels
kelly.michels@autodesk.com
3ds Max Senior QA / 3ds Max Beta Manager
M&E Division Beta Administrator
Autodesk, Inc
 
Old 10-10-2012, 10:14 PM   #3
Hannamations
Veteran
portfolio
Hannah Benbow
Animator
USA
 
Join Date: Jan 2011
Posts: 59
-How do I post a scene file? :/

-3dsMax 2012 64b

-Yes it does occur in the camera view as well

-I collapsed the UVW map for the texture

-Scanline

- What is VP? :/

Thanks!
 
Old 10-10-2012, 11:24 PM   #4
Innovator
Frequenter
 
Innovator's Avatar
Matt Griffey
Visualization Specialist
iDL WorldWide
Portland, USA
 
Join Date: Mar 2004
Posts: 150
VP is viewport...do you see that mapping scale issue in the viewport as well as the rendered frame?
__________________
WIP 1969 Chevrolet Camaro Z28
 
Old 10-11-2012, 06:17 AM   #5
Hannamations
Veteran
portfolio
Hannah Benbow
Animator
USA
 
Join Date: Jan 2011
Posts: 59
Ah,duh. I've viewed it in perspective, front and ortho. It does not give me that issue in the viewport, only when rendering.
 
Old 10-11-2012, 07:22 AM   #6
coldside-digital
Know-it-All
portfolio
Daniel Dye
Tweed Heads, Australia
 
Join Date: Apr 2006
Posts: 299
Send a message via MSN to coldside-digital
Almost looks like you could have 2 pieces of geometry right in the same position, one with the larger scale texture. This can cause the issues you mentioned as when geometry is right on top of each other, the renderer can get confused as to what is supposed to be in front/behind.
__________________
http://www.youtube.com/user/coldsidedigital - 3ds Max Tutorials

http://coldsidedigital.tumblr.com - 3ds Max Blog
 
Old 10-11-2012, 12:14 PM   #7
robinb
Expert
 
Join Date: Jul 2003
Posts: 2,917
Quote:
Originally Posted by coldside-digital
Almost looks like you could have 2 pieces of geometry right in the same position, one with the larger scale texture. This can cause the issues you mentioned as when geometry is right on top of each other, the renderer can get confused as to what is supposed to be in front/behind.


Ah yeah could be this. I had exactly this situation yesterday only I had different materials on each and I couldn't work out why they wouldn't change when I selected them and changed the mat id. In this case it was two poly elements on top of each other, but both parts of the same object.
 
Old 10-11-2012, 02:34 PM   #8
Hannamations
Veteran
portfolio
Hannah Benbow
Animator
USA
 
Join Date: Jan 2011
Posts: 59
So I think I probably found the culprut now that you mentioned 2 pieces of geometry. I'm using scatter for the little pieces of hay that stick out, and that creates a second hay bale (which has the texture issue), but when I render it, it doesn't show up.



Is there a way to get rid of that extra geometry. I can't seem to select it individually.

Thanks again everyone
 
Old 10-11-2012, 06:20 PM   #9
Innovator
Frequenter
 
Innovator's Avatar
Matt Griffey
Visualization Specialist
iDL WorldWide
Portland, USA
 
Join Date: Mar 2004
Posts: 150
yes, in your scatter object there is a checkbox for hide distribution object (or something similar to that). Let me know if you cant find it and ill post a screengrab
__________________
WIP 1969 Chevrolet Camaro Z28
 
Old 10-11-2012, 06:33 PM   #10
Hannamations
Veteran
portfolio
Hannah Benbow
Animator
USA
 
Join Date: Jan 2011
Posts: 59
Yep! That did it. Thanks so much!
 
Old 10-11-2012, 06:33 PM   #11
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,480
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:40 PM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.