Use_background: renderview ok..renders not

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
  1 Week Ago
Use_background: renderview ok..renders not

I have a scene with use_background applied to a plane (as terrain) so I can catch a shadow from an object moving through the scene. When I use Render View to check things, it looks okay and the shadow appears, etc. --But when I then Batch Render the scene, the use_background plane is black...not transparent as expected. Alpha channel is selected in the Render Settings, and I can tell the shadow is there, but for some reason when actually rendering the frames it isn't transparent--just a black blob. Why it works in Render View but fails in the actual render images...don't know.

If it matters, I've come back to this scene from a year ago, and back then I'd been testing rendering with Arnold and Redshift. The terrain plane is named "ShadowCatcher_terrainshape" which leads me to think I'd originally applied an Arnold material to it. But because I don't want to have to change other Mental Ray materials in the original scene, I've switched back to rendering with Mental Ray and so I've applied the "use_background" material to this plane now. Could that have something to do with the problem...maybe some Arnold attribute is locked in??
As I said above, it works in the Render View image, but not in the final renders, and both are rendering using Mental Ray now.

Anyone have a clue on this...I'd appreciate the help.
JTT
 
  1 Week Ago
To follow-up, I've attached an image to illustrate the problem. The left image is what it should look like, this sample is taken from the 'Render View' window and shows the small shadow that's caught on the plane with use_background applied. It also renders fine if I enable rendering with 'mentalRay' in the the view panel. But if I try to actually render the image...the plane goes black as shown on the right. I've read online that some people have had issues with Final Gather in the render settings, so I'm checking on that...and at the moment I do feel it's something in Render Settings, but if anyone has other ideas, I'd appreciate the info. Thanks.
 
  1 Week Ago
this line is confusing...It also renders fine if I enable rendering with 'mentalRay' in the the view panel.

Why are you using a Maya node instead of MR mip_matteshadow or a rayswitch?
 
  2 Days Ago
Well, since you have a point and I really don't have a good answer why I was using 'use_background', I switched to 'mip_matteshadow'...

So, I've made some progress and can now get the shadows to appear and the shadow catching plane to be transparent instead of black... hallelujah! That said, I'm getting a strange result in that the plane with mip_matteshadow applied has the background image much brighter than should be. See the attached image.

I've played with some of the available settings hoping to find the one that's causing this, but so far no luck. Both images, the one used on the image plane in the background as well as the one mapped to the mip_cameramap node, are the same images in the same image sequence, so why one appears brighter than the other is a mystery to me.

Any thoughts, anyone? Thanks..

 
  1 Day Ago
I'm suggesting you to find a mip_matte_shadow workflow and don't use the imageplane for render final image but mip_camera_map and the relative correct color space(gamma)

https://www.youtube.com/watch?v=DF078Nnt8Rw
__________________
www.darioortisi.it
MayAdvanced Blog
My youtube channel
 
  16 Hours Ago
I'm a bit confused by what you wrote, so forgive me if I need some clarification. Fwiw, I've used mip_matteshadow at times in the past with good results, and I've actually seen that youtube video before as well, and the Zap's tips he referred to. Even so, I started over and recreated all the nodes step by step as shown in the Youtube video, and inserted another simple plain, just to see if I might have missed something. Unfortunately, I still get the same result. Whatever geometry has the mip_matteshadow applied still shows up brighter than the image plane background.

Looking closely, it's almost as if there is a translucent quality to the lighter area, like looking through very thin milky glass, and the foreground areas are still fairly clear and distinct, but the farther back the plane goes the more fuzzy the image seems to get. I've checked lighting, and reflectivity every where I can think of (in case that was it), but so far testing and retesting...no change.

That said, I don't understand what you meant by "don't use the imageplane for rendering the final image"? My understanding (and it was this way in the video) is that you have to have an image plane to provide the background to match what is being mapped to the matteshadow geometry (the plane in my case.) So how can I not use the image plane for the final render?

Thanks for the help..
 
  12 Hours Ago
please look at this. On the first you can see the alpha 0 for the image plane. I'm usually fix it to -1(negative 1)

https://www.youtube.com/watch?v=yGjkGw2F8gE
__________________
www.darioortisi.it
MayAdvanced Blog
My youtube channel
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:49 PM.


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.