Maya 2014 SP2: 082190: contour rendering and unified sampling are incompatib​le

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 11 November 2013   #1
Question Maya 2014 SP2: 082190: contour rendering and unified sampling are incompatib​le

Hi Folks,

Running into an odd issue on Maya 2014 SP2.

I have two (2) render layers in my scene - Beauty layer, AO layer.

The Master (disabled) and Beauty layers are configured to render out in Mental Ray (MR) Unified Sampling.

The AO layer has the following Overrides applied:

- Initial default Occlusion Preset
- Sampling Mode override: Legacy Sampling Mode
- Enable Contour Rendering selected
- Around All Poly Faces selected


Regardless of the render approach - Render View or Batch Render - I receive the following error message during render:

"082190: contour rendering and unified sampling are incompatible, switching contours off"

If I disable the Beauty render layer and re-render with only the AO layer selected, I see the results that I expect - i.e. contour lines in my AO pass. It's as-if Maya is skipping over the Sampling Mode override settings that I applied to the AO layer.

I'm with working around the issue by rendering the AO pass on it's own, but I'm curious to know if anyone else has run into this issue. BTW, if someone has a better technique to obtain wireframe, I'm most certainly open to trying it out.

Cheers,


* EDIT *

Interesting ... I just discovered that if I don't intentionally select the AO layer prior to rendering, I get the above noted error message.

Last edited by hgagne : 11 November 2013 at 07:25 PM.
 
Old 11 November 2013   #2
1. In the Render Settings, instead of rendering with MentalRay, switch the "Render Using" dropdown box to Maya Hardware 2.0.


2. Enable Multisample Anti-aliasing and set either eight or sixteen.


3. Under Batch Render Options, set Render mode to “Wire On Shaded.


4. Create a display layer and add all objects you wish to wireframe to this layer.

5. Select the color box next to the layer name and select the color black. When objects are not selected, this will make their wireframe render black.

6. Replace all object materials a white surface shader.

*This method will show proper lineflow on smoothed geo and is batch renderable.
 
Old 11 November 2013   #3
Originally Posted by LowJacK: 1. In the Render Settings, instead of rendering with MentalRay, switch the "Render Using" dropdown box to Maya Hardware 2.0.

2. Enable Multisample Anti-aliasing and set either eight or sixteen.

3. Under Batch Render Options, set Render mode to “Wire On Shaded.

4. Create a display layer and add all objects you wish to wireframe to this layer.

5. Select the color box next to the layer name and select the color black. When objects are not selected, this will make their wireframe render black.

6. Replace all object materials a white surface shader.

*This method will show proper lineflow on smoothed geo and is batch renderable.



Hi LowJack,

Much appreciated;

Currently, I used the steps noted here (http://forums.cgsociety.org/showpos...44&postcount=17) after I discovered that Batch Render does indeed work with Vector render provided one doesn't attempt to select Batch Render > Options.

I'm going to give the steps you have posted a try so as to see the results and as a learning exercise. FYI, I was trying to obtain a Low Poly Wireframe on a Smoothed (3 key, aka Hi Poly) render so as to avoid performing a Modify > Convert > Smooth Mesh To Polygons.

Cheers,
 
Old 11 November 2013   #4
Hi LowJack,

I think I'm missing a step as the output render is completely black in the Render View; steps I followed:

Originally Posted by LowJacK: 1. In the Render Settings, instead of rendering with MentalRay, switch the "Render Using" dropdown box to Maya Hardware 2.0.


Created a new Render Layer and added the objects to it. Selected the Render Settings for the Render Layer and enabled the following options as Layer Overrides ...

1. Render Using set to Maya Hardware 2.0
2. Enable Multisample Anti-aliasing and set to 16
3. Under Batch Render Options, set Render Mode to "Wire On Shaded"

4. Create a display layer and add all objects you wish to wireframe to this layer.


Created a new Display Layer and added the objects to it. Selected all the objects in the newly created layer and replaced all materials a new Surface Shader.

Selected the color box next to the layer name and select the color black. When objects are not selected, the wireframes are black in the Viewport as expected.


Cheers,



* EDIT *

The problem was not selecting the Object Type Filter > UI checkbox in the Maya Hardware 2.0 render settings.

Posting this here for folks who may be after the same solution. This will allow one to render the "construction" (aka Low Poly) mesh in either unsmoothed (1 key) or smoothed (3 key).

1. Create a new Render Layer.
2. Add the objects to it.
3. Select the Render Settings for the Render Layer.
4. Enable the following options as Layer Overrides:
- Render Using set to Maya Hardware 2.0
- Enable Multisample Anti-aliasing and set to 16
- Under Batch Render Options, set Render Mode to "Wire On Shaded"
- Under Object Type Filter, enable the UI option
5. Create a new Display Layer.
6. Add the same objects to the new display layer.
7. Create a new Surface Shader material.
8. Assign the material to the objects in that are part of the new display layer - should be same objects as in render layer.
9. Set the color box next to the display layer name to the desired color (ex: black, blue, etc.). When objects are not selected, the wireframes will be this color.
10. Use the Render View to confirm and Batch Render as required.



Credit to the kind folks at Autodesk Support as well as CGTALK user LowJack.

Last edited by hgagne : 11 November 2013 at 10:14 PM.
 
Old 11 November 2013   #5
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:03 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.